Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Local sandboxed instance of vanillaforums not importing correctly

Hi guys,

Just wondering if anyone could possibly give me some ideas/clues as to why I'm having this issue.

I'm working on a MyBB porter so I have a local sandboxed version of the forums installed so that I can do my testing. I can export the information just fine, but when I try and import the information into my forums, I get the following message:

Row 1 doesn't contain data for all columns|Gdn_Database|Query|load data infile '/Sites/vanilla.dev/uploads/import/User.txt' into table GDN_zUser character set utf8 columns terminated by ',' optionally enclosed by '"' escaped by '\' lines terminated by '\n' ignore 1 lines

I kept on thinking that I was doing something wrong within my code, but I couldn't see anything. Finally, I decided to run some tests. I installed SMF 2 locally, created some dummy users, exported that information, tried to import, and still, I got the same error. So now I knew it wasn't my code because the official SMF2 importer wasn't working either.

So, I installed a remote instace of vanilla forums on my host, I took that same old file from the mybb export, and I was able to successfully import the information onto my remote instance of the forums.

Can anyone think of a reason why this is happening? On both, I'm using the same version of php, the same version of vanilla forums, and the same version of the vanilla porter.

Thanks

Best Answer

  • hgtonighthgtonight ∞ · New Moderator
    Answer ✓

    It is possible your local MySQL server is in strict mode. Be sure to double check that as Vanilla doesn't support MySQL strict mode.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Answers

  • If you exported on Windows, let's first take a look in the bug reports on github. There's something wrong with the "lines termination" on windows compared to Linux (your host). I filed a bug report and it's solution some time ago, go through the open bug reports

    There was an error rendering this rich post.

  • HoLyCoWHoLyCoW New
    edited July 2014

    I actually exported it on a Mac. I even took the exported text file and manually changed the line endings, re-saved it, and tried importing. I did this with Windows, Mac, and Linux line terminations and in all three cases, the import didn't work.

  • This doesn't answer my question of "Why does the import feature of the local installation of Vanilla Forum not work, when doing it remotely does?"

    Unless you mean to say that I can use these tools to export my information so that I can import them into Vanilla.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Unless you mean to say that I can use these tools to export my information so that I can import them into Vanilla.

    Yes that is what I mean.

  • This Row 1 doesn't contain data for all column is a mysql error, so you need to solve that error. After that, figure out why the row didn't get generated properly on your Mac and did get generated properly on your Linux host

    We wish you all the luck in the world with that and just update the bug report on git hub when you're done :-)

    There was an error rendering this rich post.

  • hgtonighthgtonight ∞ · New Moderator
    Answer ✓

    It is possible your local MySQL server is in strict mode. Be sure to double check that as Vanilla doesn't support MySQL strict mode.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight said:
    It is possible your local MySQL server is in strict mode. Be sure to double check that as Vanilla doesn't support MySQL strict mode.

    THANK YOU!!!! This was it!

    I had never even heard of MYSQL Strict mode. I figured out how to disable it and it all works well.

    Thanks a lot!!!

Sign In or Register to comment.