Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

"Couldn't send message" when using Firebase?

I'm probably missing something...

I created an account at Firebase, then copied the firebase URL (xxxx-xxxx-xxxx.firebaseio.com) and secret into the Van2Shout settings page, then copied security rules from the V2S settings and replaced the existing rules on my Firebase with them.
I'm using the version of the plugin found here: http://vanillaforums.org/discussion/27229/caerostris-some-changes-diff-didn-t-display-too-well-for-me

When I post a message in the shoutbox, it very briefly appears then disappears and a pop-up saying "Couldn't send message" is displayed. What am I doing wrong?

Comments

  • Options
    AccentAccent
    edited August 2014

    No idea?

    edit: I'd also like to know if it's possible to change the shoutbox page's url, but that's not very important so I don't know if I should create a separate thread for it

  • Options

    No idea on what might be going wrong? @caerostris‌, @lifeisfoo‌, anyone? I'd rather keep using this for now rather than an IRC plugin...

  • Options
    hgtonighthgtonight ∞ · New MVP

    I have no experience with this plugin, but I use an embedded iframe with a quakenet webchat for on page IRC access.

    It is pretty nice for a web client.

    http://webchat.quakenet.org/

    Then I pre-populate the fields with a room, nick name, and ui scheme like below:

    http://webchat.quakenet.org/?nick=hgtonight&channels=vanilla&uio=d4

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    lifeisfoolifeisfoo Zombie plugins finder ✭✭✭

    Hi @Accent, if you send me more informations (web browser console log, complete source code, etc) I can help you. I ran it more then one year ago, so I'm don't know how it is evolved during this period. Moreover firebase is a fast evolving platform and probably some APIs are different.

    There was an error rendering this rich post.

  • Options

    Hi, sorry I couldn't reply earlier. I don't know what kind of source code you're looking for... The plugin is unadultered, and I followed all of the instructions in the download page to set up Firebase. I managed to send one message, but since then nothing works. Here is the browser console log:

    Login to firebase succeeded! van2shoutpage:8303
    FIREBASE WARNING: on() or once() for /private/Accent failed: Error: permission_denied: Client doesn't have permission to access the desired data.  firebase.js:35
    FIREBASE WARNING: set at /broadcast/*** failed: permission_denied  firebase.js:35
    FIREBASE WARNING: set at /broadcast/*** failed: permission_denied  firebase.js:35
    

    Does that help?

  • Options

    I have this problem as well.

  • Options

    Phew, why do things always go wrong? :neutral_face:
    I'll check it out next week :)

  • Options

    Okay, I just deployed a new demo server and tried enabling firebase.
    I had the same problem.
    It seems the issue is connected to the colour checks in the firebase rules.
    As soon as you change your colour to a non-default one, firebase magically starts working.
    I'll look into this when I find the time :)

  • Options
    caerostriscaerostris ✭✭
    edited December 2014

    Turns out I fixed it some time ago (Nov 2013) but the update never made it to vf.org.
    The git branch works and I'll push the update to vf.org in the coming weeks :)

Sign In or Register to comment.