HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Authors can not edit messages

Hi !

Using-

http://vanillaforums.org/discussion/24152/editing#latest

I have set a time limit of 15 minutes in which the Authors can edit messages.

Doesn't seem to be working. I can see a "Gear" Icon and an "Edit " option beneath but clicking on it leads me to -

" Permission Problem
You don't have permission to do that."

Using Vanilla 2.1

All help appreciated ...

Tagged:
«1

Comments

  • peregrineperegrine MVP
    edited August 2014

    only authors can edit their own messages, or their time ran out.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes, it is the Author only trying to edit his own message ...

    Just found that my Forum>Advanced Settings are NOT being saved ! I set it to "Authors may edit for 15 minutes" , save it but next time when I access it , it has reverted to " Authors may never edit " !

    Advise please !

  • Yup..reconfirming above ? !

  • Just found that on another Vanilla install where I put 2.1 from scratch I am not facing this issue. But on this site I earlier had Vanilla 2.0.18 when I was facing User Permission problems. Finally I overwrote the core files to Vanilla 2.1 and the problem went away . See -

    http://vanillaforums.org/discussion/27413/user-permissions#latest

    But it does NOT seem to have gone away completely !

    All help appreciated ...

  • if you set it properly

    and you want 15 minutes.

    you should see this line in your config.php

    $Configuration['Garden']['EditContentTimeout'] = '900';

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Yes I can see that line in my config.php ....!

  • Disabling all the plugins doesn't help - so the problem is not a conflict with a plugin.....

  • peregrineperegrine MVP
    edited August 2014

    your answers don't jive in my mind.

    Just found that my Forum>Advanced Settings are NOT being saved ! I set it to "Authors may edit for 15 minutes" , save it but next time when I access it , it has reverted to " Authors may never edit " !

    $Configuration['Garden']['EditContentTimeout'] = '900';

    Yes I can see that line in my config.php ....!

    it should be reading the config value that is set in the config file.

    is that still an issue.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I can understand what you mean - but Advanced Settings are not being saved and the config.php shows Timeout as 900, as you say !!

  • This is how it looks presently
    ...

  • Finding that I can vary the " Discussions Per page " and " Comments per Page " setting but NOT the "Discussions and Comments Editing" setting !?

  • change the setting to Users may edit for 1 hour and save it.
    AFTER the change

    then post what it say says in config.php for

    $Configuration['Garden']['EditContentTimeout']

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Logged in as admin, changed teh setting to one hour. logged out. Now config.php says

    $Configuration['Garden']['EditContentTimeout'] = '3600';

  • Logged back in. Still says " Authors may never edit " !!!

  • peregrineperegrine MVP
    edited August 2014

    if you want to try to debug,

    log in as Admin

    https://github.com/vanilla/vanilla/blob/2.1/applications/vanilla/views/settings/advanced.php#L31

    change around line 31

    <?php
     decho($this->Form);`
    

    and then post what it says for

    [Garden.EditContentTimeout] =>

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Did above. Now when i go to advanced settings I get a lot of code below which is the setting for " Discussions and Comments editing ". Changed it to one hour. Then the code that I get in the debug screen above is as attached- your code line seems to be appearing at many places... .

    When I log out and login again , the value is again " Authors may never edit " !!!

    This is rather frustrating - this behavior does NOT show up in the Forum where I put Vanilla 2.1 from scratch so I am sure it has something to do with the " upgrading " I did....

    Pl advise. Many thanks

  • hgtonighthgtonight ∞ · New Moderator

    This is almost certainly a caching issue.

    Put an exception in your caching system, if possible, for /conf.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrineUnderDog
  • And how do I do that ?

  • peregrineperegrine MVP
    edited August 2014

    are both forums on the same host - the one that works and the one that doesn't work.

    if caching is the issue.

    find out what caching you are using look in phpinfo for caching info or ask your host.

    e.g. apc might use this

    http://stackoverflow.com/questions/16888049/php-apc-exclude-folder-from-caching

    but if it is caching wouldn't the cache read the true config.php values sooner or later which are properly set.

    I wonder if it is something else.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes both forums on the same host - hostgator

Sign In or Register to comment.