Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Problem with Wordpress Plugin

Hello,

I have Vanilla 2.1 embedded in Word Press. Everything seems to be OK with the embed script. I imported users from Joomla into Word Press but unfortunately those users can not use the SSO functionality. I've tried logging in as one of the WP users with no success. I am also not able to register from Vanilla even though my SSO settings have been completed to jsConnect. See screenshot.

http://screencast.com/t/1jVfzYOqi

Attempting to register results in a 404. See screenshot. http://screencast.com/t/xBFGPMct2

Any ideas would be appreciated.

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Welcome to the community!

    1. Did you copy those settings into the jsConnect plugin settings page in Vanilla?
    2. Please regenerate your secret, as you have posted a screenshot containing it.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I did both, thanks :)

    I think I'm making some headway. I only have one issue now. The default sign in link on the embedded forum takes me to the vanilla popup sign in page, which apparently is only vanilla authentication. Is there a way for it to take me to the WP login page instead? I know the hosted version has an option not to use the popup for sign in on the advanced embed settings, but open source doesn't seem to have this option.

    (ill try not to post anymore secrets)

    http://screencast.com/t/UZhpyuvBiFiJ

    http://screencast.com/t/eN8hPdrT

  • Options
    hgtonighthgtonight ∞ · New MVP

    Submitting the Vanilla entry form when the registration method is set to connect should forward the user to your SSO login page.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    jaymzjaymz New
    edited August 2014

    I'm still trying to figure out why that isn't happening. The user registration is set to connect. The jsConnect parameters are there. Test works.

    Sign in will not redirect and the Howdy, Stranger box is missing buttons.

    http://screencast.com/t/jaY8uyLWhGJV

    http://development.texasoutdoorexchange.com

  • Options

    Im going to run through these steps, some of the issues sound familiar.

    http://vanillaforums.org/discussion/26436/implementing-sso-using-jsconnect-1-4-1-with-vanilla-2-0-18-10-part-i

  • Options

    Just realized those steps are not related to the WordpRess plugin, so back to square one. I will continue to troubleshoot and report back.

  • Options
    jaymzjaymz New
    edited August 2014

    OK. I've tried everything I can. I can't see a reason why the Sign In and Register links in the embedded forum would not be reflected what is stored in jsconnect.

    Here is what I have setup in jsconnect

    http://screencast.com/t/3NzrELyHJvkE

    I even added the variables to config.php as shown here:

    $Configuration['Garden']['SignIn']['Popup'] = FALSE;
    $Configuration['Garden']['Authenticator']['RegisterUrl'] = '/wp-login.php?action=register';
    $Configuration['Garden']['Authenticator']['SignInUrl'] = '/wp-login.php?Target=%2$s';
    $Configuration['Garden']['Authenticator']['SignOutUrl'] = '/wp-login.php?action=logout&redirect_to=index.php';
    

    unfortunately, here is what the Sign In link points to (the default)

    http://screencast.com/t/ph7ryER7eZcp

    What am i missing?

  • Options
    hgtonighthgtonight ∞ · New MVP

    Try the following configs:

    $Configuration['Garden']['Authenticator']['RegisterUrl'] = '//development.texasoutdoorexchange.com/wp-login.php?action=register';
    $Configuration['Garden']['Authenticator']['SignInUrl'] = '//development.texasoutdoorexchange.com/wp-login.php?Target=%2$s';
    $Configuration['Garden']['Authenticator']['SignOutUrl'] = '//development.texasoutdoorexchange.com/wp-login.php?action=logout&redirect_to=index.php';
    $Configuration['Garden']['SignIn']['Popup'] = FALSE;
    $Configuration['Garden']['UserAccount']['AllowEdit'] = FALSE;
    $Configuration['Garden']['Registration']['Method'] = 'Connect'; 
    

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I tried that as well to no avail.

    Thank you so much for your help. You've been very kind. I'm continuing to troubleshoot.

    I've changed the meBox in the locale file so I have that one solved.

    Now the issue seems to be with the foot asset - the helper_functions.php file calls when it calls Garden.SignIn.Popup. It's looking for the SignInURL and RegisterURL but or whatever reason those variables aren't being pulled in from the config for this authenticator.

    I could hard code them in the file, but that doesn't seem like a good solution. The text wasn't available in the locale to transcribe either.

Sign In or Register to comment.