HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

"Attach a file" link not displayed when editing a comment

This discussion is related to the fileupload addon.
DoyceTDoyceT Model Questioner ✭✭✭
edited August 2014 in Vanilla 2.0 - 2.8

Hi all,

Using 2.1.1 stable, version 1.8.2.1 of file upload, and default template.

If I start a new discussion, the attach a file link is there and works fine.
If I start a new comment, the attach a file link is there and works fine.
If I go back and edit a previously created discussion, the attach a file link is there and works fine.
If I go back and edit a previously created comment, the attach a file link is not there.

On our forum, commenters frequently have to attach files (usually Word documents with track changes/comments enabled with feedback on someone else's work), and if they write their comment, save it, and forgot to attach the file (it definitely happens), they can't correct the error - they can only make a new comment, which gets messy and spammy in short order.

What I'm looking for is where I would need tweak the addon to display the attach a file link when editing a previously created comment.

Comments

  • thats a deficiency. As far as I can tell there is no easy way with edit comment, also difficult to attach anything to form view while editing comment without modifying core, or creating a plugin like the editor on this forum with file attachment. Lincoln said there would be a new editor like vanilla forums editors, when is the question.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    DoyceT
  • DoyceTDoyceT Model Questioner ✭✭✭

    One more reason to look forward to getting access to the editor on this forum, sounds like. :)

Sign In or Register to comment.