Please upgrade here. These earlier versions are no longer being updated and have security issues.

Login, Register, Sign Out links not replaced by Jsconnect

Hello,

I am trying to get a fully functional SSO up and running. The sign on part of the code works just fine however the account links are not redirecting to my main site. I am using jsconnect 1.41 with Vanilla 2.1.1. I have the link set in the jsconnect settings. I tried vanilla master branch 2.2.16 and jsconnect 1.4.1. With this combination, all the links functioned and would forward to my main site for login, register sign out ect.. and jsconnect button shows up with my user name. However, when I click that link to login it attempts to login with the information but simple redirects back the the forum and the jsconnect button shows login again. The user is created if its the first time but the login just doesn't stick. I also tried jsconnect 1.0.3b and it did not replace the links but I can login with SSO.

So,

Does anyone know how to get the account links to redirect properly Using Vanilla 2.1.1 and Jsconnect 1.4.1? I am not sure what I am missing with the links. The master branch the links just work except for the actual login so I would figure the link replacement mechanism is there in the 2.1.1 branch but maybe there is some extra config I am not aware of.

Any help would be greatly appreciated.

Comments

  • I was really hoping for a little help...

  • hgtonighthgtonight ∞ · New Moderator

    Set the registration method to connect and specify the signin/out links in your /conf/config.php file:

    $Configuration['Garden']['Authenticator']['RegisterUrl'] = '//www.example.com/wp-login.php?action=register';
    $Configuration['Garden']['Authenticator']['SignInUrl'] = '//www.example.com/wp-login.php?Target=%2$s';
    $Configuration['Garden']['Authenticator']['SignOutUrl'] = '//www.example.com/wp-login.php?action=logout&redirect_to=index.php';
    $Configuration['Garden']['Registration']['Method'] = 'Connect'; 
    

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrineShadowdare
  • Thanks for the reply. adding those settings did make all the account links like sign in and register work but now the jsconnect login stopped working. that could be due to switching over to the 2.1 git branch vs the download from the vanilla site though. However I was able to get everything to work on the master branch after a minor update form 2 days ago. Apparently that was also breaking jsconnect as well at the setup stuff.

  • Hmm... I may have to look at this update because I've been getting the whoops page every time I click to signin with the current sso user session.

  • Would you mind linking to said update? I'm unable to see it, and git pull isn't showing any updates for me.

  • peregrineperegrine MVP
    edited September 2014

    jo jsconnect - master changes are here, (nothing new in 2.1 branch in recent times)

    https://github.com/vanilla/addons/commits/master/plugins/jsconnect

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @hilabuster mentioned a change from two days ago, a change I don't see in the logs.

  • edited September 2014

    On the master branch not the 2.1 branch.
    https://github.com/vanilla/vanilla/commits/master

Sign In or Register to comment.