Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Yaga 1.0 doesn't show configuration in admin-sidepanel

phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
edited September 2014 in Vanilla 2.0 - 2.8

Hi all,

I have a running version of Yaga 0.6 on one forum (Vanilla 2.1.1). Fine!

But my problem is on another forum i'm trying to use Yaga 1.0. Interestingly it's shows that it is activated and also shows me the "Gamification" header in Vanilla's admin panel. The "Settings" are also shown (and Yaga "works" in the frontend), but Reactions, Badges, Ranks do not appear. So i'm not able to configure them. Strange.

I activated $Configuration['Debug'] = TRUE; and ran into a
Fatal Error in YagaHooks.UserModel_AfterGetSession_Handler(); (see screenshot)...

Anyone has any ideas if it's a configuration fault or a bug?!

  • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
  • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
Tagged:

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Was this a fresh install of Yaga or an upgrade?

    Try running /utility/structure

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited September 2014

    Hi @hgtonight,

    It was a fresh install of Yaga, but the Vanilla DB is coming from a phpBB import, what shouldn't be of importance i guess.
    I ran /utility/structure, didn't help...

    Maybe a rights issue? Hhmm. Thanx for your help!

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Options
    hgtonighthgtonight ∞ · New MVP

    What are the Yaga configs in your /conf/config.php show?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP

    // Yaga $Configuration['Yaga']['Version'] = '1.0'; $Configuration['Yaga']['Reactions']['Enabled'] = '1'; $Configuration['Yaga']['Badges']['Enabled'] = '1'; $Configuration['Yaga']['Ranks']['Enabled'] = '1'; $Configuration['Yaga']['LeaderBoard']['Enabled'] = ''; $Configuration['Yaga']['LeaderBoard']['Limit'] = '';

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Options
    peregrineperegrine MVP
    edited September 2014

    wild guesses and noise until hgtonight comes back :)

    do you have a Ranks Table? are there any values in it?

    maybe the return of Perks needs to be checked if it is null.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    phreak, it would be interesting to see if you have the same problem installing 0.6 instead on your forum that doesn't work, to see if it is a version issue vs. something else.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited September 2014

    Arrgl, knarf, uaaagggh. Sorry guys, i didn't have the permissions by default. I found out by calling the URLs that should be behind the menue points in the admin panel and i got a "Permission Problem".

    Those URLs:
    /action/settings for Reactions /badge/settings for Badges /rank/settings for the Ranks

    I could have thought of this earlier, as with the import of a former phpBB database and my current Admin user not being the user with ID1 i encountered several settings to fix. It just didn't happen to me before that i only had a rights situation for some functions of Yaga.

    So for anyone else running in the same problem: Switch over to Roles & Permissions and fix it there.

    Thanx for the help @hgtonight and @peregrine!

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Options
    hgtonighthgtonight ∞ · New MVP

    The error you saw when debugging is still troubling, but I am glad you got it sorted out!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.