HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla Forum comment integration wordpress

spellyspelly New
edited September 2014 in Vanilla 2.0 - 2.8

Hey, i have a little problem with the comment integration plugin in Wordpress.

The problem is that the post button is partly hidden in every article. Look here:

How to fix?

Seems like the same problem is in: chrome, ff and ie.

Theme: Pinboard.
Wordpress: 4.0
Site: http://aquazoo.no/leksikon/stonefish-synanceia-verrucosa/

Regards,
Spelly

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Your post was caught in the spam filter, sorry about that.

    Considering this is a CSS issue, I am paging @vrijvlinder.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok you need to fix two things, the div for the comments and the height of the iframe for the comment box, you add this code to the css of wordpress theme.

    iframe#vanilla54527{
    height: 100%;
    min-height: 300px;
    }
    
    div#vanilla-comments{
    min-height: 300px;
    }
    
    hgtonightperegrine
  • Hey,
    thanks for the help.
    I added the CSS ,but it seems like it didnt work?
    http://reefzone.no/hvitprikk-i-saltvannsakvarie-cryptocaryon-irritans-forebyggelse-og-behandling/

  • peregrineperegrine MVP
    edited October 2014

    where did you add it? exactly which css?

    iframe#vanilla89056 {
    height: 100%;
    min-height: 300px;
    }
    

    your id will change if you change site - you can always find the id with your web browser console.

    if need be make min-height important.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok try this then , again inside the wordpress theme where you put the other code line 3276

    div#vanilla-comments, iframe {
    min-height: 300px!important;
    }
    
    peregrine
  • you also have an image problem here

    background-image: url("http://dreamaquarium.no/leksikon/wp-content/uploads/2014/03/1624243.jpg");

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • peregrineperegrine MVP
    edited October 2014

    believe it or not - you are using vanilla 2.1.3 - that is what the "vanilla 2.1 help" category is for !

    "vanilla 2.0 help" category would be used when you have a version of vanilla 2.0.x e.g. 2.0.18 installed.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.