Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Vanilla's Transifex moved - rejoin your team!

ToddTodd Chief Product Officer Vanilla Staff
edited October 2014 in Localization

Hi all, we've been doing a lot of translation house cleaning over the past couple of weeks. We've also transferred the Vanilla project from a personal account into an organization. As a result of this it looks like everyone got booted off their respective teams (which I didn't realize would happen).

If you are looking to translate can you please apply to a team at Vanilla's new home here. Thanks so much.

Adrianhgtonightvrijvlinderkelime

Comments

  • LincLinc Director of Development Detroit Vanilla Staff

    We're looking for help reaching out to folks who were previously on our teams but aren't any more. We'd like to get them re-added.

    If you PM someone you know was helping with translations, post it here so we don't all message the same folks a dozen times. Be sure to send them a link to the new Transifex project.

  • freelancingcarefreelancingcare Dhaka, Bangladesh

    This action cannot be performed because the organization has outgrown its current plan limits. Please contact the organization administrators.

    showing that

  • ToddTodd Chief Product Officer Vanilla Staff

    Thanks for the note. We have a support ticket open with Transifex.

    LifeBEC
  • JasonBarnabeJasonBarnabe Cynical Salamander ✭✭

    I see locales being updated on the addons site, which is great assuming that this means they've been updated from Transifex.

    What Vanilla versions are these locale packs compatible with? I assume they're synced up to the latest 2.3; would running them with 2.1.3 cause any problems?

    LifeBEC
  • JasonBarnabeJasonBarnabe Cynical Salamander ✭✭

    Great. I'm trying them out now, and I found two issues so far:

    1. There's lots of locales packs for the same language with no indication what the difference is. For example, there's 5 French locale packs - I'm assuming one is "new" (2014.10.24p2055), one is "old" ( 2012.10.23p1109), one is for 2.0, and two are unofficial. It'd be great if we could get the "old" one removed, add the word "official" to the ones that are official, and indicate the applicable Vanilla version for the official ones.
    2. When downloading locales with country codes (e.g. pt-BR or zh-TW), the add-on listings indicate a version number like "2014.10.24p2055", but when you download it, you get "2012.09.06". For these, you need to click on the latest version on the right side before downloading.
  • JasonBarnabeJasonBarnabe Cynical Salamander ✭✭
    edited October 2014

    3 In previous versions, in definitions.php in the "Locale" key, country-specific locales were in the format zh-TW. Now they're in the format zh_TW. Was this change intentional?

  • LincLinc Director of Development Detroit Vanilla Staff

    @JasonBarnabe said:
    Was this change intentional?

    Yes.

    LifeBEC
  • ToddTodd Chief Product Officer Vanilla Staff

    Hey @JasonBarnabe‌, to add to @Linc's comment. We removed most country codes to aid with paid translation services.

    LifeBEC
Sign In or Register to comment.