Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

I don't get it ...

This plugin seems cool, but I guess I'm too dense to understand if it's working or not. When I enable it, I don't see any options nor do I see any new permissions. All I noticed is it seems to have broken my "Discussion and Comment Editing" drop down. It can now not be changed from "Authors may always edit" whether the plugin is enabled or disabled. Before enabling the plugin the drop down value saved just fine.

So, now I seem to be stuck with authors always being able to edit their own posts, which is not what I was going for at all...

Any ideas?

Also I did the following edit before activating as mentioned in another post:

public function Gdn_Dispatcher_BeforeDispatch_Handler($Sender) {

Comments

  • Options

    @cclubb said:
    This plugin seems cool, but I guess I'm too dense to understand if it's working or not. When I enable it, I don't see any options nor do I see any new permissions. All I noticed is it seems to have broken my "Discussion and Comment Editing" drop down. It can now not be changed from "Authors may always edit" whether the plugin is enabled or disabled. Before enabling the plugin the drop down value saved just fine.

    So, now I seem to be stuck with authors always being able to edit their own posts, which is not what I was going for at all...

    Any ideas?

    Also I did the following edit before activating as mentioned in another post:

    public function Gdn_Dispatcher_BeforeDispatch_Handler($Sender) {

    if you are using 2.1 - why would you make that change, I thought that change was for vanilla 2.0.18.x

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    hgtonighthgtonight ∞ · New MVP

    You need to add the 'Plugins.AlwaysEdit.Edit' to a role to see what happens.

    The dropdown appears to be broken because your account is a super admin (and all super admins have all permissions all the time). Whatever setting you choose in the dropdown and save gets saved for everyone else.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    cclubbcclubb New
    edited October 2014

    @peregrine - The changelog indicates the addon hadn't been updated since -- so I just assumed the same issues that existed for 2.0.18.x applied to 2.1. Either way- I reverted the change.

    @hgtonight - How do I add that to a role? I don't see any settings anywhere or any new checkboxes in the roles sections...? Also, I am talking about changing the settings in the Forum Settings - > Advanced section of the dashboard. Now they seem to be stuck on "Authors may never edit".

    Like I said, I think I am too dense.. lol

  • Options
    hgtonighthgtonight ∞ · New MVP

    @cclubb said:
    hgtonight - How do I add that to a role? I don't see any settings anywhere or any new checkboxes in the roles sections...?

    The plugin should have registered a new permission available in the role permissions dashboard. E.g. http://forums.example.com/role/edit/8 should have an option in the plugins block for Always Edit.

    Also, I am talking about changing the settings in the Forum Settings - > Advanced section of the dashboard. Now they seem to be stuck on "Authors may never edit".

    That is the same dropdown I was talking about.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    AdrianAdrian Wandering Spirit Montreal MVP

    Hi all,

    Sorry I was buried deep in emails and did not see this sooner. Thanks @peregrine‌ and @hgtonight‌ for helping him out ;)

    Personally, @cclubb‌ I recommend you use Yaga with Ranks, than use this plugin. It will give you a lot more bang for the buck and has this option as something you can auto-assign ;)

  • Options

    Thanks everyone -- I got it figured out with your help. After I reverted the original edit I did for the wrong version forum (I'm an idiot) -- then disabled and re-enabled the plugin I got it to work.

    Thanks for the quick replies everyone -- you are all awesome as usual.

  • Options

    Please use more descriptive titles.

    grep is your friend.

Sign In or Register to comment.