Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Users cant edit signatures

I have checked the box under roles and permissions.
The only users who can edit their Signatures seem to be users with Admin set to 1 in the database.
I've tried to add every permission to a role but still no dice.

Any ideas?

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Are you using Yaga with the default configuration?

    Yaga provides Signature editing as a perk in the default configuration.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    peregrineperegrine MVP
    edited November 2014

    if you want members to edit signatures.

    go to the roles and permissions

    edit member role.

    look for the plugins header. (probably in the middle of the page).

    check the box for edit.

    click the save button.

    they might also need to have permission to edit their own profiles. to see options.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    @hgtonight said:
    Are you using Yaga with the default configuration?

    Yaga provides Signature editing as a perk in the default configuration.

    Yes i'm using Yaga along with the Signatures plugin.
    Is there a conflict betwween the two?

    @peregrine said:
    if you want members to edit signatures.

    go to the roles and permissions

    edit member role.

    look for the plugins header. (probably in the middle of the page).

    check the box for edit.

    click the save button.

    they might also need to have permission to edit their own profiles. to see options.

    Yep already did all of that. Like i said only the user with Admin =1 in the database can edit their signature.

  • Options

    the simple way to test if conflict is to disable the yaga app temporarily and see if signatures work.

    but I haven't tested.

    I do know signatures on its own works correctly with edit checked.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Yep its not Yaga. Tested it locally now and same issue.
    Created a new user with every permission, including edit Signature.
    Same problem.

    Short video > http://screencast.com/t/bcey4SpiT

  • Options
    peregrineperegrine MVP
    edited November 2014

    look in the permissions table and see if Plugins.Signatures.Edit is checked with 1 for the specific role id.

    https://github.com/vanilla/addons/blob/master/plugins/Signatures/class.signatures.plugin.php#L119

    I can't view screencast of flashplayer.

    but can you post an attachement screenshot of what you click on and the error message screenshot.

    I assume you disabled Yaga when you tested.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Yes theres a 1 in that column in mysql on role id 108600 (my admin group).
    I disabled and moved Yaga out of the applications folder.

    What i click

    Error

    Error source

    1.png 105.3K
    2.png 135.8K
    3.png 330.1K
  • Options
    hgtonighthgtonight ∞ · New MVP

    @JoakimT said:
    Yes i'm using Yaga along with the Signatures plugin. Is there a conflict betwween the two?

    No. The default transport file sets up a perk system that restricts signature editing until you get a better rank.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    @hgtonight said:
    No. The default transport file sets up a perk system that restricts signature editing until you get a better rank.

    So i guess since i tested with it disabled and the files removed from the applications folder it should not be causing this. I never imported the default transports file either.

  • Options
    peregrineperegrine MVP
    edited November 2014

    I just want to say you have an odd role id 16800

    theoretically your role ids would be less than 100.

    you might want to list the first 2 columns of your roles table of the database where you have the issue.

    the above may be a red herring.

    also

    Could you try a fresh test install on your local host test machine without any plugins except signatures and see if it works for you.

    if you want you could also debug by putting in variable checks etc with either the logger plugin or

    via

    http://vanillaforums.org/discussion/26786/tutorial-how-to-enable-a-debug-log-and-collect-debugging-information#latest

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    peregrineperegrine MVP
    edited November 2014

    do you also have profile edit option checked.

    that causes signature settings to have a permission problem if unchecked.

    I know in 2.0 that was the default setting for members was with edit profiles checked.
    but not sure what the default setting for vanilla 2.1, or if things changed, can't recall if that gives too much permission or not.

    perhaps someone else who hasn't tweaked their members permissions settings could chime in if edit profiles is checked or unchecked by default for members.

    also see http://vanillaforums.org/discussion/comment/201467/#Comment_201467

    I'm recommending you change settings - but that was the impact last time I explored it.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    JoakimTJoakimT New
    edited November 2014

    @peregrine said:
    I just want to say you have an odd role id 16800

    theoretically your role ids would be less than 100.

    Its a migrated forum from phpBB3, thats why the roles have high id's.

    @peregrine said:
    do you also have profile edit option checked.

    From what i can see there is no profile edit option in 2.1
    Im guessing the default is that i can edit my profile, since everyone can edit their profiles :)

    @peregrine said:
    I just want to say you have an odd role id 16800

    theoretically your role ids would be less than 100.

    you might want to list the first 2 columns of your roles table of the database where you have the issue.

    Sure, heres the Roles table

    and the permissions table (part of it)

    @peregrine said:

    Could you try a fresh test install on your local host test machine without any plugins except signatures and see if it works for you.

    if you want you could also debug by putting in variable checks etc with either the logger plugin or

    via

    http://vanillaforums.org/discussion/26786/tutorial-how-to-enable-a-debug-log-and-collect-debugging-information#latest

    Locally i am running a fresh migrated installed with only the Signatures plugin enabled.

    This is the debugger info when i get to the Permission Problem page..
    (Also heres a pastebin of it -> http://pastebin.com/UVD36mjT)

  • Options
    hgtonighthgtonight ∞ · New MVP

    It looks like you enabled the Debugger plugin. This doesn't tell us the whole story.

    Please enable debug mode by adding $Configuration['Debug'] = TRUE; to your /conf/config.php file.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    If i enable Debug and open the page all i see is this...

    Something is wrong with the permissions. This is my permissions page..

    This is a completely fresh install without any migrated data...

  • Options
    hgtonighthgtonight ∞ · New MVP

    Have you run /utility/structure?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    When i enable Yaga locally with debug enabled i get this ->
    http://pastebin.com/tmVTZ2RU

    I'll try that structure thing

  • Options
    JoakimTJoakimT New
    edited November 2014

    Thank you so much. /utility/structure restored my permissions again.

    Still getting that error when i enable Yaga though.

  • Options
    peregrineperegrine MVP
    edited November 2014

    Still getting that error when i enable Yaga though.

    so now signatures work correctly now, I assume now that you have a profiles edit options and it is checked.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    hgtonighthgtonight ∞ · New MVP

    @JoakimT said:
    Thank you so much. /utility/structure restored my permissions again.

    Still getting that error when i enable Yaga though.

    Let's take that back to the other discussion: http://vanillaforums.org/discussion/28429/why-do-i-get-this-error-when-debug-is-on

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    @peregrine said:
    so now signatures work correctly now, I assume now that you have a profiles edit options and it is checked.

    Yes, thank you very much for all the help.

Sign In or Register to comment.