Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Yaga.Badge.

This discussion is related to the Yet Another Gamification Application addon.

Vanilla version: 2.1.3
Yaga version: 1.0

I really like the addon, but I'm having a few issues. The first being that everything is printed out in code. "Yaga.Badge.EarnedHeadlineFormat" instead of "You earned the First Comment badge" etc.

Same thing in the dashboard. Yaga.Reactions.Use, Yaga.Badges.Use, Yaga.Transport.Desc

Tried to figure it out on my own, but I've got nothing. Am I lacking a pre-requisite?

Comments

  • R_JR_J Ex-Fanboy Munich Admin

    What you see is the standard translation that is used when there is no translation file for your language. Your locale files and the locale files of YAGA are named differently. If you like the english translation, just copy the locale/en-CA

    omfgblondie
  • My Locale is set to en-CA in vanilla. Do I need to copy the files from YAGA into the vanilla locale?

  • I just went into the Locale and hit "Save" and now it works properly. Strange, but at least it works!

    R_JAaronWebstey
  • hgtonighthgtonight ∞ · New Moderator

    @omfgblondie said:

    Am I lacking a pre-requisite?

    Thanks for trying my addon!

    There is a step in the installation instructions requiring you to force refresh the locale due to a bug in the framework associated with application enabling. The instruction is excerpted below:

    2. Finally, you need to delete the /cache/locale_map.ini file to force refresh the locale definitions.

    Let me know if you have any other issues!

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    R_JAdrianCodervaultDeprecatedz
  • I had the same issue, and it assigned some badges before I realized what was happening and deleted the .ini file.

    The way to fix that is manually go into the GDN_Activity table and edit the HeadLineFormat field to match the older ones that are correct.

    Check your forum's activity feed to see which how many more you have to catch. :)

    hgtonightCodervault
  • AaronWebsteyAaronWebstey Headband Afficionado Cole Harbour, NS ✭✭✭

    @omfgblondie said:
    I just went into the Locale and hit "Save" and now it works properly. Strange, but at least it works!

    This worked for me too.

  • subdreamersubdreamer San Jose, CA

    I can confirm that going to Locales and saving your language choose fixes this issue in Vanilla 2.2.

Sign In or Register to comment.