Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Oops! That page cannot be found. On clicking a link in the forums

Hi there,

I recently added vanilla to my wordpress website projectb.me/forums

I installed the vanilla forums plugin on my website to embed it and everything went fine, however now whenever i click a link i get
Oops! That page cannot be found.

I think this as something to do with the rewrite or URL ? i don't know exactly maybe the plugin is dorment or i can chagne something in the hardcode?

Thank you for taking your time reading this, and i hope you can help me

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    Your server is not rewriting URLs properly. I tested this by visiting http://projectb.me/forums/index.php?p=/discussion/2/ready-for-the-first-raid and noticing the page works as expected. I am guessing you have a server misconfiguration.

    There should be a .htaccess file in your forum install folder. This is the modified version you probably need:

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /forums
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    If that doesn't work, and pretty URLs don't matter to you, you can disable them by editing the config file:

    1. Open /conf/config.php
    2. Find $Configuration['Garden']['RewriteUrls'] = TRUE;
    3. Change to $Configuration['Garden']['RewriteUrls'] = FALSE;

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.