Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
After February 6, this site will no longer have Facebook, Twitter, or OpenID sign-in options. Read our announcement about social media SSO support in 2.8 for more info.

Make sure you have a current, valid email address set in your profile and set a password so you can login without it. If you get locked out after that time, you can choose "Forgot Password" to fix it as long as a valid email is on your account.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Upgrading to 2.1.6 from 2.0.18

edited November 2014 in Vanilla 2.0 - 2.3

This is been an hours long process thus far, mostly because GDN_Activity is 2.6GB on my forum.

So after watching the mysql process list go through that and getting passed gateway timeout issues on upgrade, index.php?p=/utility/update now only shows:

The update was not successful.

Debug Trace

Info Need to re-index theme cache
Info Need to re-index plugin cache"

With no other information despite having debug mode on.

index.php?p=/utility/structure/ shows:
/* 'unique index UX_Tag (Name)' => 'unique index UX_Tag (Name, CategoryID)' */
alter table GDN_Tag
drop index UX_Tag;
alter table GDN_Tag
add unique index UX_Tag (Name, CategoryID);

but if I try to run that I get:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'alter table `GDN_Tag`
add unique index UX_Tag (`Name`, `CategoryID`)' at line 4
## *edit*/library/database/class.database.php(302): Gdn_Database->Query(...)
#0 [internal function]: Gdn_ErrorHandler(256, 'You have an err...', '...', 302, Array)
#1 *edit*/library/database/class.database.php(302): trigger_error('You have an err...', 256)
#2 *edit*/library/database/class.databasestructure.php(330): Gdn_Database->Query('/* 'unique inde...')
#3 /*edit*/library/database/class.mysqlstructure.php(522): Gdn_DatabaseStructure->Query('/* 'unique inde...')
#4 *edit*/library/database/class.databasestructure.php(392): Gdn_MySQLStructure->_Modify(false, false)
#5 *edit*/applications/dashboard/settings/structure.php(597): Gdn_DatabaseStructure->Set(false, false)
#6 *edit*/applications/dashboard/controllers/class.utilitycontroller.php(310): include('/srv/www/lafixe...')
#7 [internal function]: UtilityController->Structure('all', '0', '0', '0')
#8 *edit*/library/core/class.dispatcher.php(350): call_user_func_array(Array, Array)
#9 *edit*/index.php(46): Gdn_Dispatcher->Dispatch()
#10 {main}

Wow forum ruins formatting but not sure how to prevent that.

I should note that I've already cleared out the caches, disabled all plugins, and set the theme to default.

So I ended up manually deleting the index UX_TAG and then the update and structure ran cleanly. Now if only you guys would update the vanilla classic theme to work properly with this release :)



Sign In or Register to comment.