Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Can't enable plug ins

Hello,

Iam using NGINX with Vanilla 2.0. When I browse to the dashboard and select plug-ins I get the following in the access logs and no error;

SRC IP Retracted - - [25/Nov/2014:16:20:59 +0000] "GET /settings/plugins/all/AddMenuitem/EGYDE5LQ31W8 HTTP/1.1" 302 5 "http://IP-retracted/settings/plugins/all" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"

SRC IP Retracted - - [25/Nov/2014:16:20:59 +0000] "GET /settings/plugins/all HTTP/1.1" 500 24849 "http://IP-retracted/settings/plugins/all" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"

Tagged:

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Welcome to the community!

    If you are unable to enable plugins, you probably either have caching enabled on your /conf/config.php file or the plugin requirements are not met. Try middle clicking on the enable link to open the page in a new tab and report back what happens.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Thanks for the welcome!

    I've tried middle clicking and it opens a new page but still does not enable the plug-in.

    I've also queried this file vanilla/conf/config.php

    for a "cache" string and did not find a response.

  • Options

    check your permissions on your conf folder and the config.php

    config.php must be writeable.

    run phpinfo and see if any caching is enabled.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Permission on the files are as such
    drwxrwxrwx 2 root root 4096 Nov 25 17:52 conf/

    Here is a list of cache values from the phpinfo.php

    Additional .ini files parsed /etc/php5/fpm/conf.d/05-opcache.ini, /etc/php5/fpm/conf.d/10-mysqlnd.ini, /etc/php5/fpm/conf.d/10-pdo.ini, /etc/php5/fpm/conf.d/20-json.ini, /etc/php5/fpm/conf.d/20-mysql.ini, /etc/php5/fpm/conf.d/20-mysqli.ini, /etc/php5/fpm/conf.d/20-pdo_mysql.ini ****

    realpath_cache_size 16K 16K
    realpath_cache_ttl 120

    user_ini.cache_ttl 300

    session.cache_expire 180 180

    Etc, can you specify what value we are looking for?

  • Options

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    its not going to solve your problem per se.

    but why are you using vanilla 2.0.x?

    I would put my effort into installing vanilla 2.1.6

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    I've upgraded to 2.1.6 and see the same issue, Iam following the steps you indicated to address the caching issue.

    It appears as though I've enabled one of the plug-ins. I will report back shortly once I attempt to get a bit more set up. Thanks!

  • Options

    How do I close this as solved and credit you?

  • Options
    peregrineperegrine MVP
    edited November 2014

    @Martialshot said:
    How do I close this as solved and credit you?

    discussions are usually not closed. Generally one reports back on how they solved the problem. What steps did they take to solve, so it might help other people.

    regarding credit, you just click awesome or insightful on comments that were insightful or helped you solve issue and say thanks.

    you've already said thanks, you are welcome

    regards,
    peregrine and hgtonight (I'll speak for him :) )

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.