HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Upgrade failure - 2.1.8

edited January 2015 in Vanilla 2.0 - 2.8

I'm attempting to update to 2.1.8 from my old 2.0.18 (yeah, I know, should have done it before).

Here's the error messages from index.php?p=/utility/update

Failure

The update was not successful.

Debug Trace

Info Need to re-index theme cache
Info Need to re-index plugin cache

I'm trying to do this on an mirrored site (so there are a bunch of references in the db to the old url - changed from forum.example.com to forum2.example.com). The original is still running.

I switched to the default theme in the confg.php file, but I also deleted some theme and plugin files before trying the conversion. I suppose that might be the issue?

Tagged:

Comments

  • LincLinc Detroit Admin

    Try again after grabbing 2.1.8p2 http://vanillaforums.org/addon/vanilla-core-2.1.8p2

    Sorry for the trouble.

  • edited January 2015

    Sorry - still get same re-index plugins and theme cache message.

    I reverted to the original 2.0.18 DB to be sure the first failed attempt hadn't done somethings.

    BUT - the update process ran quite a bit longer than with the p1 version, so p2 did do something different.

    The forum does come up and seems to work mostly okay. The Categories don't show properly, and the Categories admin page gives the same re-index message.

    My database is about 65MB with a few thousand discussions and users.

    If it would help, I can give you total access to the running test site since it is not live.

  • BleistivtBleistivt Moderator
    edited January 2015

    The re-index plugins and theme cache messages can be ignored.

    Do you still get the message that the update failed?

  • LincLinc Detroit Admin

    The updater still does most of the work even if it fails 1 part, which is why it took longer previously. The new run is only re-trying the little bit that didn't work.

  • It still says the update failed, but so far most everything seems to be working okay - just some tweaking and updating plugins.

    I will assume it is safe to ingore the plugin/theme re-indexing since they seem to work still.

  • I am also having the same issue, upgrading from 2.0.18. I wonder if there's an issue around upgrading from that version?

  • Turns out it was a bad plugin :\

  • AnonymooseAnonymoose ✭✭
    edited January 2015

    Turn off pluigns except HtmLawed and try utility/update.

  • LincLinc Detroit Admin

    @lfolco said:
    Turns out it was a bad plugin :\

    What plugin?

  • A custom plugin written by the original developer who did the initial site setup :)

  • @Linc‌ @Anonymoose‌ I'm getting the same error, which I also got a few days ago when I upgraded from 2.1.6 to 2.1.7. It says "Failure, the update was not successful". I've tried clearing out my cookies/cashe and I've reverted back to the default theme, but still it's failing.

    Everything seems to be working fine though..

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Make sure that you fix the htaccess file because that gets overwritten and your pretty url is not going to work if the settings are wrong.

    Also make sure you have the config for RewriteUrl TRUE . Those two things need to be correct in order for the utility links to work.

    Skisma
  • AnonymooseAnonymoose ✭✭
    edited January 2015

    @Skisma said:
    Linc‌ Anonymoose‌ I'm getting the same error, which I also got a few days ago when I upgraded from 2.1.6 to 2.1.7. It says "Failure, the update was not successful". I've tried clearing out my cookies/cashe and I've reverted back to the default theme, but still it's failing.

    Everything seems to be working fine though..

    Add:

    $Configuration['Debug'] = TRUE;

    to your /conf/config.php and run update again. It will tell you what is going wrong when you run update. You might have incorrect permisisons that need to be fixed or some other thing that you can easily do, but you won't find out what it is unless you turn on debug.

    vrijvlinderSkisma
  • @Anonymoose‌ @vrijvlinder‌ Thanks guys! The debug said:

    Info Need to re-index theme cache
    Info Need to re-index plugin cache

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ignore those they are only informational not really errors...

    check htaccess

    check config.php for $Configuration['Garden']['RewriteUrls'] = TRUE;

    Post htaccess contents if above is TRUE

  • DenisSDenisS My brain hurts Buriram ✭✭

    after upgrade to 2.1.8 from 2.1.7 I have lost from the bottom of the dashboard 3 system checks/ database/ after upgrade check, for the life of me i can't find out where i got them from in the first place, I have looked at plugins and in the config.php but nothing seems to relate to it. is it a plugin? if so what it called?

  • @DenisS said:
    after upgrade to 2.1.8 from 2.1.7 I have lost from the bottom of the dashboard 3 system checks/ database/ after upgrade check, for the life of me i can't find out where i got them from in the first place, I have looked at plugins and in the config.php but nothing seems to relate to it. is it a plugin? if so what it called?

    http://vanillaforums.org/addon/utilitylinks-plugin

Sign In or Register to comment.