Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Release 2.1.8, blank after update embedded in Wordpress latest version.

As requested, I have started this discussion separately, I cannot remove my comment from the other one.

Release 2.1.8, forum page blank after update embedded in Wordpress latest version.

So, I got this advice from @morepotatoes (thanx!):
"On the database table GDN_Tag, delete the index named UX_Tag, and then run it again. It should then regenerate correctly."
Where on my server do I find this tag? I use bluehost.

I have attached the latest error log entries from Wordpress which occurred after i refreshed the faulty page (since it is embedded it ends up there right?)

I have left my site so it is non-functioning for now. Here is the address to the forum: http://www.gringo-rio.com/rioforum-2-2/

Many thanks!

Hakan

Comments

  • Options

    Sorry, forgot to add. I have gone through the troubleshooting guide.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Sorry you are having these issues.

    Have you enabled debugging by adding $Configuration['Debug'] = TRUE; to your /conf/config.php file?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    OK! Now we're getting somewhere. I had missed that, now I attached the errorlog from therioforum. It says there is a problem on line 18. It says:

    $Configuration['EnabledPlugins']['VanillaInThisDiscussion'] = ;

    I tried to add TRUE to the end but nothing changed. Also, after I added the debug entry to the config.php file, the forum snippets in my widgets on Wordpress disappeared...

    Ideas?

    H

  • Options
    hgtonighthgtonight ∞ · New Moderator

    I don't quite understand what you are talking about.

    I don't see any attachment.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Oops, i was sure I had attached it. I tried to attach in the wrong format, sorry! Here it is:

  • Options

    Verify that you uploaded all the files to your server, looks like the core files are not complete.

    Also delete all .ini files from the cache directory (you can try that first).

  • Options

    Ok, I uploaded again. Cleaned the cache from ini files too... same problem.

    So, I added the value TRUE to line 18 which was stated in the errorlog, then an error referring to the plugin AptAds occured, I removed apt ads line in config.php in there. Now it is referring to this error instead: [17-Jan-2015 23:32:42 UTC] PHP Notice: Undefined index: DisplayAs in /home2/theriofo/public_html/therioforum/applications/vanilla/models/class.categorymodel.php on line 156

    which has the following code: if ($Category['DisplayAs'] == 'Default') {
    if ($Category['Depth'] <= C('Vanilla.Categories.NavDepth', 0))
    $Category['DisplayAs'] = 'Categories';
    else
    $Category['DisplayAs'] = 'Discussions';
    }

    Is there something wrong in that code perhaps?

  • Options

    No, you just had to visit utility/update, which I just did for you :)

  • Options

    You need to update your embed code. Disable the embed plugin, it has been integrated into the core in 2.1.

  • Options

    Wow, this I will do now. How the hey did you get into the utility/update? I've been trying for days... What http address did you use?.

    Many thanks!

  • Options

    Ok, so I just need a bit of help here. I have changed the config.php as in the file attached. I guess I'll have to activate the embed function in the core. Since I get no access to the dashboard (is there a way I haven't found) I guess I have to change values in some file. I read a guide for converting from the Vanilla embed plugin that said you should go to:

    “Dashboard” > “Forum Settings” > “Embed Forum” and clicking “Enable Embedding”

    This must be able to do manually on the server right? Do you know where I do this?

  • Options

    Ok, I managed to figure it out with your help! I enabled the embedded version and now it works like a dance!

    Many thanks!

    Hakan

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @Hawakai‌ You need to remove that attachment. It has your db credentials in plaintext.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Sorry, which attachment do I have to remove in the config.php?

    Also, another issue I don't know how important it is. Now I can't access the Admin tab ;) Well I have attached a file with the error message I get.

    In the error log it only says: [18-Jan-2015 12:49:58 UTC] PHP Notice: Undefined index: kmode in /home2/theriofo/public_html/therioforum/plugins/SocialLogin/class.SocialLogin.plugin.php on line 495 which is referring to if($_GET['kmode'] == 'remove'){
    Gdn::SQL()->Delete('UserAuthentication', array('ForeignUserKey' => $_GET['provider_id'],'UserID'=> $Is_User_Login));
    $Sender->InformMessage(T("Your Account have sucessfully Deleted"));
    $Sender->RedirectUrl= Url('profile.php');
    }
    which I think is unrelated.

    //H

  • Options

    Sorry, which attachment do I have to remove in the config.php?

    No, you need to remove your first attachment in this thread, because your database credentials and secret keys are in there and you just shared them with everyone.

    Anyway, you better change your database password now, and get new secret keys from reCaptcha.

    Also, another issue I don't know how important it is. Now I can't access the Admin tab ;) Well I have attached a file with the error message I get.

    Disable the SocialLogin plugin.

Sign In or Register to comment.