Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't Enable

Trying to enable this plugin in 2.1.8. The loader becomes visible for an incredibly short period of time, then vanishes again.

Comments

  • hgtonighthgtonight ∞ · New Moderator

    What do you mean by loader?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • agcyphersagcyphers Nooooop.

    The little "hey, I'm workin' hea'" gif that progress from right-to-left while the Javascript executes to enable the plugin.

  • hgtonighthgtonight ∞ · New Moderator

    If that happens, there is generally an error displayed up near the top of the page.

    Do you see anything like that?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • agcyphersagcyphers Nooooop.

    Yes, the error is blank for some reason.

    The addon could not be enabled because it generated a fatal error:

    And there is nothing else.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
  • hgtonighthgtonight ∞ · New Moderator

    Ok, this means you need to inspect the network traffic and/or enable debug mode.

    Enable debug mode by adding $Configuration['Debug'] = TRUE; to your /conf/config.php file.

    Inspect network traffic by opening your browser's network panel (Ctrl + Shift + Q in FireFox). Then click on the enable button. Select the request and click on response. Paste what you see there.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • agcyphersagcyphers Nooooop.

    I fixed it last night, I just forgot to post it. The script assumes you are using PHP 5.5, and I'm using PHP 5.3 currently. I had to change line 79 of class.emailtemplate.plugin.php to be compatible as follows:

        if ($values->Result() == false)
    
    hgtonightguillermofr
  • thx for the fix, im going to update it

  • Hello!

    After I press the 'Submit' button from my dashboard/Email Templates Settings, I get this error: "403 Forbidden - Access to this resource on the server is denied!"

    -I'm running Vanilla 2.1.8

  • agcyphersagcyphers Nooooop.

    Sounds like you need to set your config file as writable.

Sign In or Register to comment.