Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

denied:ts3server://$myServer in Discussion

So like... I'm trying to create a link to my Teamspeak server inside a comment. it'll take HTML and so I figured I could simply link to: ts3server://$myServer and have it work. But I'm getting some "denied" tag in front of the url for some reason.

I saw a thread about this while someone was trying to use mailto... I just tried to search for it and couldn't find the thread again. sigh

How can I link to my TS3 server? Am I the first to try? :)

Comments

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2015

    https://support.teamspeakusa.com/index.php?/Knowledgebase/Article/View/46/16/how-can-i-link-to-my-teamspeak-3-server-on-my-webpage

    Another way to connect to a server with the TeamSpeak Windows client is via a webbrowser. The way to do it is as follows:

    teamspeak://{server_address}:{port}

    or

    ts3server://{server_address}:{port}

    The parameters in the link are "nickname", "loginname", "password", "channel", "subchannel", "channelpassword" and should be separated by "?". TeamSpeak will start up automatically and log you in according to the parameters given. Note that you do not have to enter all this information if you just want to connect to a server via your webbrowser. Just the IP address and port will do to log in to a server as a guest.

    Example:

    teamspeak://voice.teamspeak.org?nickname=WebGuest?channel=Talk

    or

    ts3server://voice.teamspeak.org?nickname=WebGuest?channel=Talk

  • Options
    SicnusSicnus New
    edited January 2015

    Yeah, I know this already.

    You can't use it as it turns; teamspeak://server.com and ts3server://server.com into

    denied:teamspeak://server.com and denied:ts3server.com

    Example test:

    connect to teamspeak

    Now, Hover over the above link. et voila. "denied:ts3server://server.com"

  • Options
    hgtonighthgtonight ∞ · New Moderator

    You need to add the teamspeak and/or ts3server schemes to be allowed in the HTMLawed plugin.

    Should be line 49 in /plugins/HtmLawed/class.htmlawed.plugin.php. Add them there.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2015

    That looks like it may be an htaccces rule blocking access to the server

    connect to teamspeak

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited January 2015

    @hgtonight said:
    You need to add the teamspeak and/or ts3server schemes to be allowed in the HTMLawed plugin.

    Should be line 49 in /plugins/HtmLawed/class.htmlawed.plugin.php. Add them there.

    brilliant ! I remember getting that on some content in the past like an image or flash but could not remember what was the reason... makes sense now. I did not know htmlawed also blocked server ip inside a link. You inspired me to go read!

    schemes
    Array of attribute-specific, comma-separated, lower-cased list of schemes (protocols) allowed in attributes accepting URLs (or ! to deny any URL); * covers all unspecified attributes; see section 3.4.3

    href: aim, feed, file, ftp, gopher, http, https, irc, mailto, news, nntp, sftp, ssh, telnet; *:file, http, https *
    *: ftp, gopher, http, https, mailto, news, nntp, telnet ^
    href: aim, feed, file, ftp, gopher, http, https, irc, mailto, news, nntp, sftp, ssh, telnet; style: !; *:file, http, https

    http://www.bioinformatics.org/phplabware/internal_utilities/htmLawed/htmLawed_README.htm

Sign In or Register to comment.