Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Welcome mail and mailchimp integration dont work

Hello everyone. I'm french and i like to use vanilla forum like this...

  1. users subscribe (it work)
  2. They dont receive confirmation message and mailchimp send them welcome mail. (Dont work)

My idea create 2 problems for me :


  1. How to disable "Welcome abroad! auto message send when a new user register?". i find it : http://vanillaforums.org/discussion/18807/is-there-a-way-to-disable-the-registration-email

But change "true" by "false" change nothing. Even delete the line :)
I desesperate. My auto welcome message look like that :

"EmailWelcome"

i dont use user validation and i dont want.


  1. Second problem is with the mailchip addon integration. I do exactly what is writing here (api key+id list enabled) :-1:

http://vanillaforums.org/addon/mailchimpintegration-plugin

But it dont work. I have not the case "subscrire to newletter" in my registration form.


I use :

Thank for your help.

Comments

  • Welcome!

    You can disable email confirmation by going to /dashboard/settings/registration and unchecking the checkbox on the bottom ("Require users to confirm their email addresses (recommended)" in english)

    I can't help you with the mailchimp plugin. You may have more luck if you open a new thread under the plugin by clicking on "Ask a Question" on the plugins page

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

  • Hi Bleistivt, thank to have take time to answer me :) I have try what you say me but it just disable confirmation message, not auto welcome message.

    i will do for plugin thank for advice :)

  • hgtonighthgtonight ∞ · New Moderator

    Disabling the welcome mail requires overriding the UserModel::SendWelcomeMail() method. I don't have a test bed in front of me, so all I could suggest at the moment is adding return true; as the first line in that method (which can be found in /applications/dashboard/models/class.usermodel.php.

    If no one else comes up with a plugin that overrides this without a core modifcation, ping me in a month and I should be able to whip something up for you.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    Bleistivt
  • Hi great thank for your help.

    1. As i dont knowed where place the "return true" i have delete it :

    "$Email->Subject(sprintf(T('[%s] Welcome Aboard!'), $AppTitle));
    $Email->To($User->Email);"

    i have try on computer and mobile and it work. I dont know if is clean to do that but it work hehe.

    1. For peoples who see this subject and try mailchimp integration. You can use the fonction "bulk mail" for see if it work. And if it not work, the board will show u the error. For me is the mailchip list who was disable by herself. i enable a new time and it work now.

    This for feedback. Great thank everyone for your help.

Sign In or Register to comment.