Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Line-break in url to '../discussion/comment' in email notification

Dear reader,

Taking over a forum for a student society running 2.1.8p2. I noticed that the link in the comment notification email wasn't working. A (not quite) random linebreak was entered. There is nothing related to the 'discussion/comment' in conf/config.php.

Follow the link
below to check it out:
http://louisbonapartesociety.nl/forum/discussion/c
omment/1753#Comment_1753

After scrolling through several fora and files I am still not able locate where the URL is constructed and hence am lost trying to find the one line break =/.

Any help would be GREATLY appreciated! Thank you in advance!

Cheers,
Chris

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    What email client are you using to view the email?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • edited March 2015

    Thank you hgtonight!

    I used the general gmail web interface (via Chrome) to view the email.

    Looking at the HTML of the link it suggests to be email client independent, but it might be that I am simply unaware of any parsing the gmail client does over the content :(

    <br> Follow the link<br> &nbsp;below to check it out:<br> <a href="http://louisbonapartesociety.nl/forum/discussion/" target="_blank">http://louisbonapartesociety.<wbr>nl/forum/discussion/</a><br> <span class="il">comment</span>/1745#Comment_1745<br> <br> Have a great day!<div class="yj6qo"></div><div class="adL"><br>

    I noticed that the older notification emails are in a different format (pre update to 2.1.8p2). Did the module get changed with the latest release? Digging into the changelogs...

  • hgtonighthgtonight ∞ · New Moderator

    Mail servers can format/parse as they see fit. Are you sending this via an SMTP server or did it "just work" out of the box?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I reckon this that bug in window's live with quoted printable.

    <wbr> is not standard and is suspiciously like windows <br>

    grep is your friend.

  • It just worked 'out of the box'. As in: someone configured it before I laid hand on it. The 'Use an SMTP server to [..]' option is unchecked.

    @x00 : how does window's live pop in it's ugly ugly head?

    I might install a plugin that does the email construction differently.

  • Actually I'm mistaken.

    <wbr> was a not standard tag, probably started by Windows or one other.

    Now it is part of HTML5 spec. It means optional line break.

    The point is it can't be vanilla, becuase that is not part of the formatting. Either some change the formatting, it some filter on outgoing mail, or most likely it is a bug in the mail client.

    The reason why I say mail client, is the vanilla is not sending a html mail, it is sending text by default. If you view it in webmail it will of course be html. So it is the mail client that is doing that.

    Check in various mail clients. it interesting it happen in .nl domains. Netherlands or perhaps confused with new line. I don't know but it not likely anything to do with vanilla.

    See if you can get the original source of the message from the webmail app.

    grep is your friend.

  • @x00 I was thinking along the same lines. Here is the relevant chunk of the original message:

    Armel Lefebvre commented on February Circle I - Monday=0A=0AFollow the link=

    below to check it out:=0Ahttp://louisbonapartesociety.nl/forum/discussion/=

    comment/1745#Comment_1745=0A=0AHave a great day!

    There does seem to be a culprit. Going to try and routing via a set SMTP.

  • This encoding was used in the past when everything was still dandy:

    X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="utf-8"`

    Whereas this is used now:

    X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
    MIME-Version: 1.0
    Content-Transfer-Encoding: quoted-printable
    Content-Type: text/plain; charset="utf-8"

  • hgtonighthgtonight ∞ · New Moderator

    I seem to recall this issue. Are you running on Bluehost by chance?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I am running on mijndomein.nl. Funny thing is that this forum's notifications are also in quoted-printable but the url of the reference isn't long enough to cause any problems =/.

  • @hgtonight said:
    Welcome to the community!

    What email client are you using to view the email?

  • My piggy icon looks great

  • @ChrisvanRun said:
    Thank you hgtonight!

    I used the general gmail web interface (via Chrome) to view the email.

  • Okay, I have deduced that the encoding WAS changed with an previous Vanilla core update:
    The library/core/class.email.php constructor now sets additional arguments for phpmailer. =/

    Seem to have somehow disabled ALL emails. So will need to fix that first before I can see if it's fixable.

  • Fixed! Setting it to '8bit' resolved the issue I had.

    https://github.com/vanilla/vanilla/issues/2640

Sign In or Register to comment.