Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Installed new version with an existing DB, can's see my content.


I have just started using on a project where the client uses vanilla forums, The website got Hacked recently and all the files were deleted and that is when I started working on this project. They told me that they had Vanilla forums installed on their website. I tried installing version 2.1.9 everything was successful during the installation but the problem is the database (all the content and the users from before the hack, which was luckily preserved) doesn't show in the newly installed version.

Can you help me fix this please. Thanks



  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Make sure that a) the database is the same and b) the DatabasePrefix is the same.

  • Options

    I have checked this.. both are the same..

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Is the config.php definitely pointing to the correct Db?

    Have you tried clearing the ini files in the cache folder?

  • Options

    yes it is, during the installation I have created an admin account which I can see in the phpmyadmin, but I have the other problem too where I can't login to the forum using that account now..

  • Options
    hgtonighthgtonight ∞ · New Moderator
    1. Backup your db
    2. Turn on the debugger so you see the real error if you have a blank screen
    3. Run // to update the DB schema if necessary.

    Do you know what the old version of Vanilla was? If it was 1.x you are going to need to run the porter.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I don't see an error, the forum loads I just don't see the content from the old DB

    I don't know the version of the forum before they lost it. as I said I just started working on this, and we don't have contact with the old developer who installed it.

    I'll send you guys a link to the forum if it would help

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    You are clearly not connected to your old DB, or you wouldn't see that page,

    Look in config.php, and you will see that it is pointing to the DB you set up prior to installation.

    You need to find the name and login details of the old DB, and put that in your config.php file and then clear the ini files from cache.

  • Options
    Jonathan WJonathan W Scranton, PA

    Are you certain that the admin account you're seeing in phpmyadmin isn't an older admin account?

  • Options

    There is nothing wrong with the actual installation. You need to need to check that the data you say it there is still there, or like other said it you are pointing to the right database with the right prefix.

    Have a look in phpmyadmin to see if you can see any of the old posts. This is why you back up before any update.

    There is little more to say on this.

    grep is your friend.

  • Options

    @whu606 @Jonathan W @x00

    I have deleted all the files and reinstalled it one more time on a new DB in teh MySQL, after the installation was completed, I have dropped the data and imported my old DB, before doing that I checked that DB again, everything is there, and the prefix is the same default prefix "GDN_"

  • Options

    Did you follow the instructions for updating?

    Normally there is no need to import when going from version of Vanilla 2 to another.

    Issues can occur if you use the porter for this

    Also if you imported with a mysql dump, then run utility/update and utility/structure after as is necessary.

    I suspect the problem you were having was due to permissions, possibly corruption in the permissions table.

    grep is your friend.

  • Options

    well the problem is, my intention wasn't updating.. as I described above the website was hacked and all the files were removed, and that is when I started working on the project.. I don't have contact with the former developer, and the owned doesn't even know what version of vanilla they had installed before the hack.

    I just downloaded and installed the latest version since that's the only one I found.

    now I can't even access or reset the password of the admin user... it doesn't send me the reset email.

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    You don't need to drop anything!

    Once you have a clean install, with a new DB (which shows the installation has been successful)

    1. edit your config.php file to point to your old DB

    2. delete the ini files from the cache folder

    That should be it.

    If there is an error, you will get a warning, and can then set config.php to report the actual error.

    I've done this quite a few times when setting up test sites, and it really is that straightforward.

    The problems you seem to be experiencing are, I believe, caused by you not following one or more of these steps.

    Please do exactly what I suggested here, and then let us know what happened.

  • Options

    I did what you said, I tried logging in with the old admin account, it let me in but it still doesn't show the discussions.. it shows me that I have 112 discussion but when I click on the link it says "No discussions were found."

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    What is the address of the forum?

    The address you gave earlier is still showing the 'basic' installation forum.

  • Options

    yes it is on the same address.. the theme is still the basic.. but I was able to access with the old admin earlier..

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    That forum is not pointing to the old DB, from what I can see.

    Look at config.php and see what DB it is pointing to.

    Then use phpMyAdmin or a similar tool to see what is in the DB.

    If your config.php was pointing to the old DB, you would either see the discussions, or it would throw an error.

  • Options

    It could be permissions based.

    When installing it creates user which you can log on with. The session hangs, then the databases is imported.

    You will see these changes until the session ends, then you won't be able to log on as it is different user.

    You can reset the password with the session hangs, or do it through the database.

    grep is your friend.

  • Options
    hnk511hnk511 New
    edited April 2015

    so on the table you mentioned there's only one row right now..

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Which is not a good thing...

    You have uses, but the discussions/comments don't look like they are in that DB.

    Try to find a different backup.

Sign In or Register to comment.