Please upgrade here. These earlier versions are no longer being updated and have security issues.

Cannot Delete PM's on Mobile Devices

Problem noticed on iOS devices but perhaps Android too. When the confirmation popup appears 'Are you sure you want to do that', the Cancel button works but the Okay button does not.

hgtonight

Comments

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    I've seen that happen too, but I have not been able to replicate it in a meaningful way to create an issue in Github. It's quite random. Sometimes, it's a loading issue and if you do it again it works. Maybe someone has luck in replicating it consistently, and can open it as an issue on Github. Please make sure to note if it's the standard mobile theme and the version of Vanilla you are using.

    Sharing is caring

  • I'm getting it on all themes, all of the time. So are my users.

    Is it possible to remove the confirmation in the mean time, by changing a setting perhaps?

  • @Adrian Can we entirely remove the confirmation from deleting messages?

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    I am sure it's possible, but I would not recommend it. It's always good to give a second chance, especially considering how fingers can make accidents on phones. What version of Vanilla are you using? Have you updated to the latest version? Have you tried to see if any plugins are causing a conflict?

    Sharing is caring

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    Wait, I just realized you are talking about Private conversations and not comments/discussions. You are not able to delete PMs in the standrad mobile theme. You can leave/delete a conversation on your desktop.

    So you may have some customization I am thinking to delete on your mobile. My original comment was related to deletion of comments & discussions. I recommend upgrading and trying to see if there is a plugin conflict before attempting to remove confirmation.

    Sharing is caring

  • Thanks,

    Using the latest version, even with plugins disabled. Just can't press the Okay button on mobile devices. I have some users that only ever use the mobile version.

  • hgtonighthgtonight ∞ · New Moderator

    @Simeon_Griggs said:
    Thanks,

    Using the latest version, even with plugins disabled. Just can't press the Okay button on mobile devices. I have some users that only ever use the mobile version.

    Can you post a screenshot?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight Any ideas?

  • ...but not on the Bootstrap theme it seems.

  • So the problem appears to be that /js/library/jquery.popup.js auto-focuses the Okay button, rendering it unpressable in iOS (in some themes)

    I changed line 45 from:

    $('#'+settings.popupId+' .Okay').focus().click(function() {

    to

    $('#'+settings.popupId+' .Okay').click(function() {

    Sorry if I have not reported/fixed this problem properly ... I understand this change will be overwritten if I upgrade the forum. But hoping someone here more knowledgable might suggest a more permanent fix!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @Simeon_Griggs said:
    a more permanent fix!

    You could add the css for focus into your mobile theme's css

    http://www.w3schools.com/cssref/sel_focus.asp

  • Yep, tried that. Added -webkit-appearance: none to the element :focus but for some reason couldn't get it to work in the Bootstrap theme.

    The more obvious fix, I would've thought, would be to remove the focus state from the button. Unless there's a compelling reason for making it focused by default.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @Simeon_Griggs said:
    Yep, tried that. Added -webkit-appearance: none to the element :focus but for some reason couldn't get it to work in the Bootstrap theme.

    Sometimes when rules don't comply, you need to add !important to them , or find the rule for focus in the default theme and edit it. There is not one theme I have encountered that I can't make it my bitch so to speak..... ;)

  • Trust me, I tried every variation of wrangling the CSS that I knew. Unless I missed something stupidly obvious (and that's a real possibility), I couldn't get it to work with edits to the CSS.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    -webkit webkit only works with webkit browsers like Safari and chrome. You need to use just focus or hover or active, depending on what it is that is causing the issue.

Sign In or Register to comment.