Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Troubleshooting ajax/js

I installed a paid theme on my Vanillaforums 2.1. This broke some parts of the forum, although I've gotten around most of it.
The problem I am trying to fix is that with this new theme, the user must refresh the page to see its own reply to threads.
Before, on other themes, it used to "flow" downwards the page and be visible instantly. This is so cool, I want to try and get it back.

I am wondering where I should start to troubleshoot this?

I am not well versed in jQuery/ajax/js, so bear with me please :)

Comments

  • Most browser have a console an inspect tool for debugging. That would be your first bet.

    grep is your friend.

  • unixherounixhero
    edited September 2015

    I found the source, although the Firefox Dev Console didn't help me, it gave some arcane errors
    "TypeError: $(...).iCheck is not a function 56756:720:0
    Use of Mutation Events is deprecated. Use MutationObserver instead. jquery.js:3:0
    Use of getPreventDefault() is deprecated. Use defaultPrevented instead."

    When I disabled the Wysihtml editor, posts started "flowing" again :)
    edit:
    it wasn't Wysihtml editor's fault, the new theme doesn't work with any editor.

  • hgtonighthgtonight ∞ · New Moderator

    @unixhero said:
    I found the source, although the Firefox Dev Console didn't help me, it gave some arcane errors
    "TypeError: $(...).iCheck is not a function 56756:720:0
    Use of Mutation Events is deprecated. Use MutationObserver instead. jquery.js:3:0
    Use of getPreventDefault() is deprecated. Use defaultPrevented instead."

    When I disabled the Wysihtml editor, posts started "flowing" again :)
    edit:
    it wasn't Wysihtml editor's fault, the new theme doesn't work with any editor.

    I would run away from this theme like my life depended on it.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrine
  • I installed a paid theme on my Vanillaforums 2.1. This broke some parts of the forum, although I've gotten around most of it.

    Almost everyone I've seen selling themes provides support on their own site.
    Wouldn't this be the best way to contact them.

    At the same time, you might want to warn other people that "such and such theme" causes problems if the author of the theme can't help you after a reasonable amount of time

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.