HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Why is there STALE information in profile on this forum.

peregrineperegrine MVP
edited September 2015 in Feedback

if the id# is not included in Link linc then the info in the about box, reactions, etc is stale and old.

http://vanillaforums.org/profile/Linc // stale

http://vanillaforums.org/profile/10878/Linc

http://vanillaforums.org/profile/comments/10878/Linc

Is this an attempt at obfuscation, caching issue, or by design, or a need-to-know basis

also

-banned user photo is not updated on leaderboard
-banned user photo in profile not updated unless the id# is used, or until stale info gets updated

I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Comments

  • LincLinc Former Staff Detroit Admin

    I don't see the profile issue.

    The leaderboard widget is cached for a while.

    peregrine
  • peregrineperegrine MVP
    edited September 2015

    thanks for reply lincoln.

    regarding recently banned user. The reaction and indexphoto showed a banned but the profile showed old photo (not banned) for hours. but eventually cleared up.
    With the exception of This weeks leader which still shows user photo instead of banned image. really insignificant issue to me.

    But the more general issue I frequently see the "last active times" are off depending on whether I look at


    • usually incorrect.

    vanillaforums.org/profile/FILLINUSERNAMEHERE

    vs.

    • usually correct.

    vanillaforums.org/profile/comment/FILLINUSERID/theusernamehere


    also the number of visits never seem to register acurately and sometimes not at all. lots of users registered since a while back and commenting in 2014 and 2015 with 0 visits!

    e.g.

    vanillaforums.org/profile/comments/57631/xxxx

    the reactions counts don't seem to update for quite some time in profile unless you click on the number itself (whether you look at your own or some one else's)

    some things could be my local caching issue in firefox or my slow connection with a unique setup.

    I wonder if anyone else has seen these issues.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited September 2015

    I am sure I have visited a million times by now but the counter is stuck at 1579, not that I care what it says but it is odd nonetheless.

    The reactions also take about three days to purge, it takes a couple of refreshing to see the new ones.

    I think it may be a cache thing, but not sure if it is me or the forum...

    I also just noticed that the banned user was not banned, I had to refresh the browser several times to get a fresher page...

    peregrine
  • peregrineperegrine MVP
    edited September 2015

    thanks for responding V.

    other caching issues that I have.

    firefox with linux and slow connection.

    With the vanilla docs I finally got it working by adding a cache buster to my link

    e.g. http://docs.vanillaforums.com/features/?x1

    without always produces this.

    http://docs.vanillaforums.com/features/

    ![](https://us.v-cdn.net/5018160/uploads/editor/bv/26bjwtie83fp.png ")

    whereas this produces.

    http://docs.vanillaforums.com/features/?x1

    I deleted cache but not browser history (which I want to keep) and reloaded pages it still won't help without the extra ?

    if I press F5 with this link http://docs.vanillaforums.com/features/

    without cache-busting ?

    then in the browser there is a little reader view image in the url space (looks like a book)

    then I get this when i click on book.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.