Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Notification settings not being updated

edited October 2015 in Vanilla 2.0 - 2.3

Originally, the notification settings were working. However, after I updated from 2.0.17.9 (yikes) to 2.1.11, this feature stopped working. I found this thread: http://vanillaforums.org/discussion/25706/solved-what-in-the-db-could-prevent-email-notifications-of-pms-being-sent which helped me trace the problem to the GDN_Permission table.

The GDN_Permission table indeed appears to be the problem, because when I import a new 2.1.11 GDN_Permission table, the feature works again. The problem is I am using the old 2.0.17.9 vf_Permission table (which I renamed to GDN_Permission, along with changing all of the other vf_ prefixes to GDN_ prefixes) to get 2.1.11 working.

I was able to further narrow down the problem to the Garden.Email.View column of the GDN_Permission table, thanks to @Linc 's and @peregrine 's comments in the above discussion. When I manually change a 0 to a 1, then the user starts getting notification emails sent successfully again.

If someone could help me figure out how to re-connect my database to the notification settings in Garden.Email.View that apparently are not getting updated correctly, I'd be grateful. I'd also be interested in learning how I can determine which user refers to which row in the GDN_Permission table so I can manually update their notification preferences if necessary. I see there is a PermissionID unique key, but I am not sure how to determine which user each PermissionID refers to.

Thanks!

Comments

  • peregrineperegrine MVP
    edited October 2015

    @gratifide sola

    with regards to your question about garden email view.

    for informational purposes....

    Don't change anything in the table.... you can control via the dashboard permissions.

    look at your role table.

    this will show the the roleid along with the rolename.

    then in the permissions table you will see the roleid column and the junction table column.

    you will see all the roles have a permission row that has a junctiontable with NULL

    your concern is these rows. The garden Email view column will have a 1 in the column for roles (ignore the 0 role) where the junctiontable is NULL.
    (exception ROLEID 0 will have 3 and the guest role should have a 0). the rest is up to you what you whether you want email view or not.

    FOR ALL ROLES except the 0 id role you can control the 1 or 0 in the garden.email.view column in the table vis the dashboard permissions. checked box equates to a 1 in the appropriate spot in the email permissions.

    see the FAQ again!
    http://vanillaforums.org/discussion/comment/219730/#Comment_219730

    As far as users who don't get email notifications. have them reset their notification preferences in their profile. this in turn is stored in the user preferences column in the user table. It is much easier to change the notification preferences in the profile instead of manually changing the table.
    And you have to hope your users are smart enough and capable of checking boxes on a web page (i.e. notification preferences in profile).

    Have any user who has a problem check and uncheck boxes and re-save their notification preferences that the desire. TIP - resave preferences. if problem.

    Always best to change via dashboard and/or via profile notification preferences.

    but since you changed to GDN (the latest default setting :) ) no need to do anything.

    FYI

    GDN is the database prefix.

    you could have changed your config to reflect the vf_

    $Configuration['Database']['DatabasePrefix'] = 'GDN_';

    or whatever

    $Configuration['Database']['DatabasePrefix'] = 'vf_';

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    gratiafidewhu606R_Jhgtonight
  • @peregrine You are like a super hero. Thanks once again. Apparently, all I had to do was check "email" in the Garden settings on the Dashboard's "roles" to fix this. Now I'm wondering what we should check for all of the other Garden settings - I see your link with the defaults. What does "Advanced Notifications" do? Is there a manual that I can read for all of these settings so I don't bore you to death with questions? ;) Thanks again.

    hgtonight
  • peregrineperegrine MVP
    edited October 2015

    gratiafide said: What does "Advanced Notifications" do? Is there a manual that I can read for all of these settings so I don't bore you to death with questions? ;) Thanks again.

    not sure if there is anything that discusses all settings. Check the wiki or documentation link or search the forum for specific setting (or grep code).

    re: advanced notification. funny you should ask. this was discussed in a discussion today or yesterday.

    the search box is the best way to find info out.

    http://vanillaforums.org/discussion/30930/sending-email-notification-to-all-members-when-discussion-posted

    if you have a lot of members be careful your mailings could get overwhelmed.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.