Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

How can I stop autosave of draft?

This discussion is related to the Stop Auto Draft addon.
ProsperProsper ✭✭
edited October 2015 in Vanilla 2.0 - 2.2

What is the best approach to stop autosave of drafts?
Unfortunately, "stop auto draft" addon failed to stop autosave of drafts!
Please what is the best approach?
Vanilla version is 2.1.12p3

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Using the plugin you've tried is the best approach. I wouldn't see a reason why it shouldn't work.
    Could you please check if there is a line starting with <script src="/applications/vanilla/js/autosave.js?v=... in the html source of a discussion page on your forum?

    hgtonight
  • @R_J - yes the code is there on the html source of a discussion page on the forum.
    See below;
    <script src="/applications/vanilla/js/autosave.js?v=2.1.12p3" type="text/javascript"></script>

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Enabling the plugin definitely stops this script from being inserted into discussion pages. Look at your config.php to find out if the plugin is really enabled. Also make sure it is accessible and complete.

  • ProsperProsper ✭✭
    edited October 2015

    @R_J Oh I just noticed that the addon does not work on mobile theme but works on desktop theme. I have added this code- 'MobileFriendly' => TRUE, to the class.stopautodraft.plugin.php
    Is it all I need to do to make the addon work on mobile theme?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Well, normally: yes. And this plugin is a very short and simple one. So I guess it should work, but I cannot tell you so without testing.

  • @R_J - thank you. I believe it works on mobile now.

Sign In or Register to comment.