Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

500 Error When creating new Discussion

xm1xm1 New
edited November 2015 in Vanilla 2.0 - 2.3

When I try to post a new discussion I get an empty pop up, when I check the console I see am getting a 500 error. But the discussion actually get posted.

This causes users to keep posting duplicate discussion without knowing.

I've tried disabling all addons, that didn't solve it.

Comments

  • peregrineperegrine MVP
    edited November 2015

    since you disabled your plugins (but not htmllawed, which you should not) ...
    also auto draft can sometimes cause issues.

    did you make sure to turn off debug in in config.php after doing preliminary debugging? sometimes that causes problems, if you don't.

    also auto draft can sometimes cause issues.

    was this an update from a previous version of vanilla?

    Anyone with update issues and 500 errors should probably provide this info in opening discussion if they want timely and responsive recovery and save people form asking these very same questions.

    did you disable all your plugins (but not htmllawed, which you should not) ...

    are you using default theme and have you verified your .htaccess is correct?

    do you have an errors with /utility/update?

    what is your version of php? have you recently updated your php? or has it been the same for weeks?

    what os are you using?

    have you deleted .ini file in cache folder?

    check error logs.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    xm1
  • peregrineperegrine MVP
    edited November 2015

    check error logs.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • LincLinc Director of Development Detroit Vanilla Staff

    When I've seen this error before, it was the result of granting the Advanced Notifications to all members, which gave email notifications for new discussions to hundreds of people who opted in. Vanilla processes those emails serially before the page reloads, which will cause a timeout if there's hundreds of emails to send. Revoking that permission from all non-admins would likely solve this issue if that's enabled on your site.

  • @peregrine said:
    also auto draft can sometimes cause issues.

    Is there a way to disable it?

    was this an update from a previous version of vanilla?

    Yes! 2.1.13

    did you disable all your plugins (but not htmllawed, which you should not) ...

    Yes

    are you using default theme and have you verified your .htaccess is correct?

    Am not using Default theme, applying the default theme didn't solve the issue.
    Reverting back to the original 2.2 and 2.1 .httaccess didn't solve the issue either.

    do you have an errors with /utility/update?

    No errors whatsoever

    what is your version of php? have you recently updated your php? or has it been the same for weeks?

    PHP 5.5.9
    I've not updated PHP recently

    what os are you using?

    Ubuntu 14.04

    have you deleted .ini file in cache folder?

    Yes

    check error logs.

    I will

  • peregrineperegrine MVP
    edited November 2015

    http://vanillaforums.org/addon/stopautodraft-plugin

    if you continue to have issues after re-reading and following all advice in previous comments in discussion. and can't find any other clues.

    you might want to post your .htaccess if you use apache.
    or if you use nginx the config for it,

    and also post your config.php (minus passwords, salts and sensitive info like email)

    also post a list of names of all files in your cache folder.
    if you have beginning with locale-developer, delete it.

    if you have this in your config

    $Configuration['Garden']['Locales']['DeveloperMode'] = true;
    
    change it to 
    
    $Configuration['Garden']['Locales']['DeveloperMode'] = false;
    

    also nothing wrong with recopying 2.2 files again, maybe you missed something.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • xm1xm1 New
    edited November 2015

    @peregrine said:
    check error logs.

    Thanks for mentioning this

    I checked and it turns out that it's an error coming from my CustomMentions class.
    I think while rewriting the class for 2.2 I introduced a bug.

    Thanks again @peregrine

    peregrinehgtonight
  • peregrineperegrine MVP
    edited November 2015

    @R_J

    it only took a few days for a bootstrap mod to bite another one :wink:

    http://vanillaforums.org/discussion/comment/235421/#Comment_235421

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    R_J
Sign In or Register to comment.