Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Issues with Discussions not appearing

This discussion is related to the Vanilla Porter addon.
PFAFFPFAFF
edited November 2015 in Vanilla 2.0 - 2.3

Had some issues with upgrading my embedded forum, so I used Porter to import into a non-embedded forum.

Everything seems to work great except when I click on a discussion I getting a server error. Messages and other stuff seems to work fine.

Using Vanilla 2.2 installed to /vanilla/ with Apache, 5.6 PHP.

Any ideas?

Comments

  • hgtonighthgtonight ∞ · New Moderator

    What error are you getting?

    Porter was not designed to transfer data from Vanilla 2 to Vanilla 2. It is not recommended.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • It gives me a 500 server error.

  • peregrineperegrine MVP
    edited November 2015

    just use phpmyadmin and export database and import via phpmyadmin.

    or sqldump

    simpler yet you can just use phpmyadmin to make an exact copy of database with a new name if you are on the same system.

    Had some issues with upgrading my embedded forum, so I used Porter to import into a non-embedded forum.

    no, no, no

    you had 2.1 or 2.2

    the instructions explicilty say don't use porter.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    @PFAFF said:
    It gives me a 500 server error.

    What does your server log report as the error?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I think it's this:

    [17-Nov-2015 07:47:01 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/apc.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0
    I also took @peregrine's advice and used MyPHPAdmin to export/import and get the same issue.

    Could this be a PHP issue? I did just upgrade to PHP 5.6.

    Thanks so much for your assistance. Stressing like crazy right now and knowing someone is interested in providing help/advice is super relieving.

  • I may need to just restore my whole website. Downloading a backup now.

  • peregrineperegrine MVP
    edited November 2015

    actually you just need to fix your php.ini probably and some of the php config files.

    it can't find the so files, either your path is wrong and fix, and or upgrade the so file as well.

    probably newer versions than dec 26, 2013.

    this is either an old library file or non-existent.

    try commenting out or fixing load paths,

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I think you're correct. When I restored my website, still has issues pulling discussions and I had a version setting error.

    So, this must be when I updated my PHP version. Any tips to update my php.ini?

  • peregrineperegrine MVP
    edited November 2015

    ask your host provider would be the easiest.

    or if you are doing it yourself check if file exists in path

    check you various PATH variables, etc. LDPATH, etc.

    run phpinfo

    determine where your php.ini file is located. depending on your os the config areas are different.

    essentially either comment out the so file in question. or get the correct version in the correct path

    just a little bit of logic of seeing what fits where.

    without knowing your os and version it is stabbing in the dark.

    does this exist

    /usr/local/lib/php/extensions/no-debug-non-zts-20131226/apc.so

    is it the appropriate so for your version of php?

    is the path to your extensions correct?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    PFAFF
  • Thanks so much! I'll look into this. Very much appreciate the help.

  • Server Version: Apache/2.4.16 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4

    So, when I go to the directory above, I see:

    pdo.so
    pdo_mysql.so
    pdo_sqlite.so

    And, my php.ini says:

    extension=pdo.so
    extension=pdo_sqlite.so
    extension="apc.so"
    extension=pdo_mysql.so

    So, I just need to comment out extension="apc.so", yes?

  • that would potentially stop the error message.

    try it.

    run your phpinfo() as well.

    see what caching you have

    apc could be replaced by a better cache method.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • if you commented out the line and it corrected your error - perfect.

    if you look at php you can see what modules and extensions you have loaded.

    you can see if you have some other forum of caching.

    as far as link - I can't tell you I don't use litespeed.

    just trying top provide suggestions for you to try.

    don't you have a host provider to give you assistance?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Commented that out.

    Now getting this error:

    [17-Nov-2015 20:18:06 UTC] PHP Fatal error: Call to undefined function mb_detect_encoding() in /home/louisvm5/public_html/forum/library/vendors/simplehtmldom/simple_html_dom.php on line 988

    Thanks for your help! Unfortunately, my hosting provider has been less than helpful since I'm on a VPS.

  • yes you need to enable it.

    see the forum - numerous messages regarding it.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    PFAFF
  • @peregrine I'm going to fix that and hopefully everything goes through correctly. I owe you a beer!!!

  • peregrineperegrine MVP
    edited November 2015

    @peregrine I'm going to fix that and hopefully everything goes through correctly. I owe you a beer!!!

    send my beer to @mtschirs

    hope things work out

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    PFAFF
Sign In or Register to comment.