Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Anyone have any idea why i-Phone users are unable to comment on specific threads?

whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

This also happened with 2.1

For some reason, very occasionally, my i-Phone users report that they are unable to post comments on a specific thread.

They can post normally for the most part, but some threads refuse to play ball.

I have absolutely no idea why, and would be hugely grateful and relieved if someone else did.

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Further to this, if they switch to the Full site option, they can post.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2015

    I have no problem posting on iPhone . I made my own mobile themes which are php based not tpl . Maybe that is why but could not be sure. Maybe it is the theme or some js interfering ...

    One way of finding out is by using a browser user agent switcher and the troubleshoot using the web inspector.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited December 2015

    @vrijvlinder

    Thanks.

    The point is that i-Phone users don't normally have any problem posting.

    Then, apparently out of nowhere, they can't post on a certain thread, which, of course, makes it really hard to figure out why.

    Just hoped someone might have happened on this before and worked it out.

    Further to being able to post if they switch to the main site, a user has reported that since doing that they can now also comment via the mobile site.

    :confused::confounded:

  • hgtonighthgtonight ∞ · New Moderator

    What plugins are you running?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited December 2015

    @hgtonight

    A bunch of the standard plugins. I can list them if you like, but I struggle to see how any of them could be causing such an intermittent user-agent specific issue.

  • hgtonighthgtonight ∞ · New Moderator

    Anything that does/does not run on mobile sites could clue us in.

    You say if they select to view the full site, the problem goes away?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @hgtonight

    Did for one user, not for another, who was also able to post from the Full site option.

    User with i-Phone 5 reports the issue, user with i-Phone 6 doesn't have it.

    What I find so difficult to understand is that it is not a general issue.

    Users affected can post normally on threads, then suddenly they can't post on a specific thread, even though they can still post on other threads.

  • hgtonighthgtonight ∞ · New Moderator

    Transient issues are a pain in the ass.

    Transient issues with a device you don't have is even worse.

    I feel your pain, but I don't have an iPhone or OSX device to help debug.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @hgtonight

    Thanks anyway.

    tbh, I posted on the (very) off-chance someone had stumbled on this and the answer.

  • x00x00 MVP
    edited December 2015

    There are two common problems one is that due to difference in how browsers apply style rules, there can be a physical overlap of elements (usually transparent) which prevent clicking. This can happen due to issues with negative margin, absolute/relative positioning, z-index issues and elements not being clear each other.

    Another issue is a specific javascript error that affect that browser stopping the flow of things.

    grep is your friend.

  • Typically users give a "does not work" answer. But doesn't give you very much information. You need to know what does not work.

    They could record a screencast

    http://www.labnol.org/software/record-screencasts-on-ipad-iphone/20958/

    grep is your friend.

Sign In or Register to comment.