HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Older Vanilla Support

This discussion is related to the Hide Gender addon.

I attempted to install this plugin in Vanilla Version 2.0.17.10.

I installed this version via my ISP's Application Manager, so I don't know when it will get updated to a newer version.

When I try and activate the plugin, I get the following "NoGender is missing the following requirement(s): Vanilla 2.1."

Is there anyway that this plugin can be update/modified to support my older version of Vanilla?

Thanks.

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @RussMartin

    Welcome to the community.

    tbh, you are asking the wrong question.

    You really, really shouldn't be using such an outdated version of Vanilla, which may contain a range of security issues.

    You should install the latest version of Vanilla on your server, which is very straightforward to do without the automated application manager.

    Ask away if you are unsure how to go about this.

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    @RussMartin, as @whu606 has pointed out, you are using a version of Vanilla that needs to be upgraded as soon as possible. In terms of removing gender, you just need to add the following to your custom.css of your theme:

    li.Gender {
    display:none !important;
    }
    
  • LincLinc Former Staff Detroit Admin

    @whu606 said:
    may contain a range of security issues.

    Does. Absolutely does contain horrifying, easily exploitable security issues.

  • 2.0 eeek you don't want that.

    grep is your friend.

Sign In or Register to comment.