HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

White error screen when store navigation link is clicked on forum front

This discussion is related to the MarketPlace addon.
ProsperProsper ✭✭
edited December 2015 in Vanilla 2.0 - 2.8

I got a white page with the words below when I clicked on the "store"navigation button on forum front;

Index of /store

  • Parent Directory
  • cgi-bin/
    Apache Server at www.myforum.com Port 80

What have I done wrong?
Forum runs on version 2.2 and MarketPlace addon version is 0.2.4b

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Do you have Pretty Urls enabled on your install?

    It looks like you have enabled index listings in your apache config. I would suggest disabling them: https://www.google.com/search?q=how+do+I+disable+index+listing+in+apache

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • ProsperProsper ✭✭
    edited December 2015

    I have this code $Configuration['Garden']['RewriteUrls'] = '1'; on config.php

  • hgtonighthgtonight ∞ · New Moderator

    What does the URL look like when you get the white page?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • ProsperProsper ✭✭
    edited December 2015

    @hgtonight - It now works. I changed the URL from www.myforum.com/store to www.myforum.com/marketplace.

    However, I added 'MobileFriendly' => true, to the default.php to make "MarketPlace" addon show up on mobile but when I click on "store" link (on mobile device), all I see is the heading "Products in Store" without the actual product listings. Please what am I doing wrong here?

    Please note that desktop "store" link works okay. It is only mobile "store' link that is not working as it should.

  • hgtonighthgtonight ∞ · New Moderator

    If a plugin doesn't call itself mobile friendly, it probably won't work very well on mobile. Changing the info array will cause the plugin to be loaded and registered, but that doesn't mean it will work.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight - yes, you are right. Nowadays, most people browse online and visit forums with mobile phones far more than they did with desktop PC. If marketplace plugin can be upgraded to work well on mobile that will be very beneficial.

Sign In or Register to comment.