Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Cannot add Categories or "save" anything

So, I was able to create two categories but now whenever I try to add a category and click "save" I get this error message:

Page Not Found. The page you were looking for could not be found.

Also, this seems to now happen every time I try to "save" a setting. I've logged out, cleared cache but nothing seems to work.

Comments

  • Even happens when I try to save an edit to a published post.

  • This is so weird. I was able to add two more categories and save some settings and now it won't do either yet again.

  • OK, so I was just able to add the category "PPC" but I still can't add one called "SEO". And I checked the database to see if that category already exists but it doesn't. I'm baffled.

  • I even tried the slug "seo2" and it says Page Not Found. But I can create categories for everything else. Is "seo" blocked or blacklisted or something?

  • For some reason, it simply will not create a category with any of those terms in the Title. So I set it to "search marketing" instead. Bizarre!

  • hgtonighthgtonight ∞ · New Moderator

    @goozleology said:
    I even tried the slug "seo2" and it says Page Not Found. But I can create categories for everything else. Is "seo" blocked or blacklisted or something?

    Not in Vanilla.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I ended up naming it something different because it just would not let me name it that. Weird!

  • edited December 2015

    It must have something to do with the actual content I'm trying to post because when I paste the text into the discussion, it always says "Page Not Found" when I try to preview, save or publish it. However, if I delete the text and just type something, it will properly save, preview or publish.

    However, I don't understand why the content would be giving me a hard time. Could it be because there's a URL?

    And FYI, when I pasted the exact same content into this discussion, this forum let me preview the discussion. So it shouldn't be something in the text.

  • It has something to do with this text because when I delete it, it posts:

    Black hat: Search engine optimization tactics that are counter to best practices such as the Google Webmaster Guidelines. We don't do this!

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Something in your set up seem to filter seo related terms - very funny! :lol:

    There is simply no explanation in Vanilla why you cannot name your category "SEO" or post "Search engine optimization".
    Do you have some exotic plugin in use?


  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Do you have some kind of spam filter operating?

  • Not that I know of. I never added a blacklist or anything. And this is a fresh install.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    If you are on a shared host, they may have implemented some kind of word filter to keep people from using blackhat seo techniques to affect page rank on google . Try adding nofollow to the links you post and see if you have the same problem. You may want to contact your host and ask them if they have something to do with it.

    https://support.google.com/webmasters/topic/6001971?hl=en&ref_topic=6001981

    https://en.wikipedia.org/wiki/Spamdexing

Sign In or Register to comment.