Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Auto-save causing popups and error messages

Whenever I begin writing a new discussion, the system tries to auto-save and I get this error message and then I can't go back to writing the rest of the discussion. What can I do?

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Do you have pretty URLs enabled?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I didn't turn it on but I do think it's enabled

  • Options

    When I check the plugins, I don't see any Pretty URLs (active or inactive) but here's an example of a post's URL: http://goozleology.net/index.php?p=/discussion/3/general-information-check-here-first#latest

    Doesn't look pretty to me.

    And now I can't seem to even post new discussions. I get the same weird popup as above.

  • Options

    And here are the plugins I have enabled:

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited December 2015

    Please look at the Tutorial "about error 404" ... you have a problem that can easily be solved if you read the Tutorial section...

    I would disable duplicate plugins. Why have advanced editor enabled and also button bar ?

  • Options

    I looked at the tutorial and there was nothing wrong with the htaccess file.

    Also, I added the line of code that was suggested to the config file.

    Finally, I disabled the Button Bar (I was aware that they did the same thing), Tagging, In This Discussion, and Stop Auto Draft plugins.

    Still having the same problem.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please post the contents of the htaccess file, maybe you missed something ?

    Try deleting the .ini files from the forum cache folder. Try disabling all the plugins and turn them on one by one to test and see if any of them are the problem.

  • Options

    `# Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    # RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    `

  • Options

    I also deleted all of the ini files and disabled all plugins. Same problem.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Just as I expected, you did miss something crucial , I don't think you read the 404 tutorial carefully. When something has a # in front of it in the htaccess file, it disables that. Please correct the file to represent your forum. If it is in / the root then just use a slash, if it is /forum add that.

    # Modified
    
    If you modify this file then change the above line to: # Modified
    
    
    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
     RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    
  • Options

    I changed it and deleted the cache ini files. Same problem.

    `# Modified

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    `

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Same problem

    With what? 404 or the plugins ?

    Please give a link

  • Options
    edited December 2015

    With the 404 that occurs when I try to Preview or Publish a discussion. I can't give you a link because I can't even publish it. It's the same problem that I created the image about at the very beginning.

    And all plugins are still disabled.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    That problem with the double text boxes ? or with the pop up ? You have multiple problems it seems. You could make a test account for us and pm the password

  • Options

    Thanks, I PM'd you the details.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    I tested and had no problems posting or editing

  • Options

    I don't get it. I keep having the same problem. Thanks for the help.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Clear your browser cache, what browser do you use ?

  • Options

    This is so weird. I cleared my cache (Chrome) and I was able to preview one discussion just one time. Then I edited the discussion some more and I, again, cannot save, preview or publish anything. It makes no sense.

Sign In or Register to comment.