Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

how to disable anchor when @ sign is in front of it

jackmaessenjackmaessen ✭✭✭
edited January 2016 in Vanilla 2.0 - 2.8

On my forum, with Googleprettify code highlighter and Html inputformatter, he handles the file @file_get_contents as an anchor. How can i disable that?

$hit_count = @file_get_contents('count.txt');

On my earlier 2.1 version with geshi code highlighting, this was not an issue. He could distinguish when @ sign in normal text (treated as anchor) and @ sign in codeblock (treated NOT as anchor). But in 2.2 with embedded SyntaxPrettifer and Html inputformatter, he is not been able to distinguish anymore...

Edit:
Found a different behaviour: when putting the line without php tags, it is treated normal without anchor:

$hit_count = @file_get_contents('count.txt');

When adding php tags around it, it is treated as an anchor ( in my case)

<?php
$hit_count = @file_get_contents('count.txt');
 ?>

Look here: http://develop3.webprofis.nl/discussion/465/test-sign-anchor-in-code

Comments

  • LincLinc Detroit Admin
    edited January 2016

    A good first step would be determining where this behavior is coming from. For instance:

    Hello @Linc 
    

    We have Syntax Prettifier enabled here, yet it's not doing it in Markdown mode. So that implies it's perhaps Html as the input formatter, which I've tested and confirmed. So this would be a reasonable issue to file on GitHub: "Mentions in code blocks should not format in Html input mode".

Sign In or Register to comment.