Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Unable to enable CSSEdit "The plugin folder was not properly defined."

This discussion is related to the CSSedit addon.

Vanilla 2.1
PHP 5.5

Scenario is as follows:

sudo wget https://github.com/bleistivt/CSSedit/archive/master.zip

sudo unzip master.zip

sudo mv CSSedit-master/ CSSedit/

Went to my dashboard>plugins and I see an unlabeled plugin at the top of my list. Mousing over the enable button I see that it is indeed CSSedit : http://69.173.125.39/vanilla/index.php?p=/settings/plugins/all/CSSedit/1BO4CODQ3UY8

When I click enable I get the following error:

"The plugin folder was not properly defined."

I tried following the previous advise from Bleistivt whereby line 3 of the class.x.x.php file has to have the name adjusted, but the name there (and through out that file) match.

Any help would be great!

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Do you have a cache enabled?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • In my browser? or in Vanilla?
    (apologies for the newbie questions - I'm just getting started with this)

  • Thank you for trying out my plugin!

    The plugin is most likely not compatible with vanilla 2.1 anymore, but this older version (1.1) should work:
    https://github.com/bleistivt/CSSedit/archive/7111f714d63493d0b82315a13533afe8fdd36674.zip

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    hgtonight
  • Ah - that makes sense. I'm upgrading to 2.2 tomorrow. So, I'll try it then and see how we do.
    Thanks!

  • Upgrading to 2.2 did the trick.

    R_J
  • I'm having the same problem but kind of backwards. Installed Vanilla on March 6, so I believe it's 2.2. Today I installed CSSedit ver. 1.2.1 from vanillaforums.org/addon and double checked that all the files are in the /plugins folder. Went to Dashboard-Plugins and saw the unlabeled double-gear symbol at top - tried to enable it and got the same fatal error as bhill681.

    Interestingly, I'm seeing other plugins on my dashboard that do NOT show in my plugins folder, and I get the same errors. And vice-versa, I'm seeing plugins that came with the installation but do not show up as available on my Dashboard-Plugins! Please explain what I need to do. Thanks very much!

  • I see on my previous post that when I did the installation I did not select ver. 2.2 and who606 replied but I didn't see it. Sorry! So should I now just upgrade to ver. 2.2? BTW - where can I see what version I have? Thanks much!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @LuxVera

    Version no. appears in the Dashboard main page, in the bottom right-hand corner.

    Bleistivthgtonight
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Also, check that you are using PHP 5.4 or higher.

  • Thank you - I hadn't noticed the version at the bottom of Dashboard. To my surprise, I am seeing Vanilla Version 2.2 ! Okay, so that's taken care of.
    My PHP version is currently 5.3.27, so I called LunarPages, and they will move me to one of their servers that has been upgraded to PHP 5.5. Will having 5.5 automatically resolve my problem with getting CSSedit and other plugins to work?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    It certainly should help with CSSEdit, which requires 5.4 as a minimum.

  • Great! It should take 24-48 hours for getting PHP 5.5, and once that happens I'll trust it will be smooth sailing. If not, I'll come knocking at your door again =)

Sign In or Register to comment.