Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Fatal error: Cannot redeclare class OAuthException library/vendors/oauth/OAuth.php on line 0

Hello Vanilla,
I have a very big problem please help me. My Forum Version: 2.0.18.8 is with this error code only because Fatal error: Cannot redeclare class
OAuthException in
/home2/ersatzte/public_html/REDACTED/library/vendors/oauth/OAuth.php
on line 0

My Hoster says the backup does not work, the code was broken and I want to ask you for help. What should I do now to repair back to the page.

Kind regards

Cartman

Best Answers

Answers

  • Options

    Hello Whu606,
    I thank you very for your answer. IM very desperate. The backup from 16.04. the restart does not work displays the same error. I do not know how long the page has been broken have too much stress and not noticed until now. And what can I do now it helps even what is to download the database or the now broken forever. And where exactly is the database because I need to copy the new Forum which folder. I thought the backup when hoster protects everything. What am I going to make as to the page can still be saved. Please help me. to use the new forum then is ok for me the main thing I can save my data.

    Best Regards

    Cartman

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited May 2016

    @CartmanoutGermany

    You need to speak to your host. The mySQL database will be separate from your Vanilla installation.

    If you can retrieve the /uploads folder from the Vanilla installation, that will maintain your user avatars and any uploaded files.

    Once you locate your database, make a copy, and store it away from your host. Then make a copy and store it with your host.

    Make a clean installation of Vanilla 2.2 with a new database.

    When you've got that up and running, post on here, and we'll talk you through linking your old DB to your new Vanilla install.

    Your English is fine, but if you find it easier to use German, I'm sure @RJ would be prepared to help you.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    @whu606 said:
    Your English is fine, but if you find it easier to use German, I'm sure @RJ would be prepared to help you.

    Natürlich!

  • Options

    Hallo Whu606 und R_J,
    ich danke euch beiden fuer eure Hilfe. Sorry das ich erst jetzt antworte aber das ganze kostet Zeit ohne Ende. FTP ging erst nach tagen wieder aber nur ungesichert sonst geht kein Kontakt zum Server egal welche Einstellung zur Verschluesselung. Dann habe ich die Seite mit dem aeltesten Backup Punkt runter geladen. Im Ordner Upload sehe ich auch sowas wie User Fotos. Aber wenn ich den Ordner in 2.2 rein kopiere dann ist die Seite wieder wie frueher alle Kategorien und das Design sind wie immer da. Oder geht das nur mir der von Whu606 erwaehnten mySQL Datenbank. Denn ich habe sowas gefunden auf dem Bedienerpanel beim Hoster aber ich kann dort weder einen einzelnen noch alle Ordner gleichzeitig runter laden es kommt ein Fehlercode. Ich mus den Hoster um Hilfe bitten. Dann hatte ich mal versucht den angezeigten kaputten Ordner zu ersetzen ging auch nicht. Habe ein Upgrade auf 2.2 gemacht ja das ging und dann war im Internet der Fehlercode weg mein Hoster nur zu sehen aber keine Seite Fehler 404 ist es wohl. Jetzt dachte ich das ganze zu deinstalieren und dann neu 2.2 drauf machen aber dann loesche ich ja wohl auch mySQL und alles ist weg oder. Wenn ich versuche die Domain auf ein neues 2.2 zu machen dann geht das nicht auch vorher nicht als es 2.1 war nur das Upgrade ging aber wie gesagt keine Seite zu sehen da steht nur das es jetzt 2.2 ist. Und ja was soll ich denn jetzt machen um die Seite schnell wieder so zu machen wie sie vorher war nur auf 2.2. Und R_J ja das ist in der Tat ein sehr spannender Webspace haha =)B) Und dachte mir ja auch das es hier fast nur um Englisch geht was ich ja nicht so gut kann aber ihr habt voellig Recht ich Poste das jetzt mal einfach in 2 Spraschen obwohl ich ja denke das ich mit eurer Hilfe ja wohl auch schon zum Ziel kommen werde. Ich danke euch.

    Liebe Gruesse

    Cartman

    Hello Whu606 and R_J,
    I thank you both for your help. Sorry that I only now reply but all costs time without end. FTP was only after days again but only unsecured otherwise not contact the server goes no matter what setting the encryption. Then I loaded the page with the oldest backup point down. In upload folder I also see something like User Photos. But if I copy the folder in 2.2 purely, then try again as they used all the categories and the design are as always there. Or is it only me mentioned by Whu606 mySQL database. Because I have something found on the operator panel when Hoster but I can there not a single yet all folders simultaneously sheetDownload there is an error code. I mus the Hoster asking for help. Then I had ever tried to replace the displayed broken folder did not work. Have an upgrade made to 2.2 so it went and then there was the Internet, the error code off my Hoster only to see but no page error 404 is well. Now I thought to deinstalieren round and then re-2.2 on it but then I make loesche probably also mySQL and everything is gone or. When I try to make the domain to a new 2.2 then does that not also previously not when it was 2.1 only the upgrade went but again no side to see it says only that it is now 2.2. And so, what should I do now to make the page quickly as it was previously only 2.2. And R_J yes that is indeed a very exciting Webspace haha ​​=) B) And thought indeed that it is almost only English here what I do not so well can but you have completely right I Poste that now times simply in 2 Spraschen although I I will probably already come with your help to target think. I thank you.

    Kind regards

    Cartman

  • Options

    Hier der aktuelle Fehlercode.

    Fatal error: require_once(): Failed opening required '/home2/public_html//bootstrap.php' (include_path='.:/usr/php/56/usr/lib64:/usr/php/56/usr/share/pear') in /home2/public_html//index.php on line 41

  • Options
    R_JR_J Ex-Fanboy Munich Admin
    edited May 2016

    Derzeit zeigt deine Homepage "Fatal error: require_once(): Failed opening required '/home2/ersatzte/public_html/REDACTED/bootstrap.php' (include_path='.:/usr/php/56/usr/lib64:/usr/php/56/usr/share/pear') in /home2/ersatzte/public_html/REDACTED/index.php on line 41" und das ist wirklich seltsam, weil require_once(PATH_ROOT.'/bootstrap.php'); nämlich ca. 10 Zeilen vorher in Zeile 32 steht. Das sieht so aus, als wäre da noch ein ganz anderes Problem...

    Dein Hosting Provider bietet Vanilla als sogenannten "One Click Installer" an. Hast du Vanilla damit installiert, oder hast du selber die Installationsdatei von hier runtergeladen und sie dann auf deinem Server installiert?

    Generelles zur Datenbank: deine Datenbank wird in einer Datei gespeichert, auf die du normalerweise keinen Zugriff hast. Die einzige Möglichkeit mit der Datenbank zu arbeiten geschieht über einen Dienst, der dir eine Schnittstelle auf die in der Datenbank gespeicherten Daten bereitstellt. Ein Backup passiert dann auch nicht dadurch, dass man die Datei der Datenbank sichert, sondern dass man mit einem Programm (ganz oft PhpMyAdmin oder Adminer) darauf zugreift.
    Dein Provider scheint cPanel anzubieten. In diesem Fall hast du dort vermutlich die Möglichkeit ein Backup zu ziehen oder einzuspielen.

    Du solltest aber mal deinen Provider darauf ansprechen. Der sollte dir sagen können, wie man ein Backup seiner Datenbank machen kann.

    Übrigens kann ich mir nicht vorstellen, dass durch das upgrade die Datenbank beschädigt wird.

    Hier ist eine sehr gute Anleitung wie man das Upgrade normalerweise machen sollte: https://vanillaforums.org/discussion/31153/tutorial-a-fool-proof-way-to-do-a-vanilla-upgrade-from-2-1-to-2-2#latest

    Viel mehr wird dir dazu eigentlich keiner mehr sagen können. Du solltest unbedingt mit deinem Provider über das Problem reden. Wenn die dir nicht helfen können hast du eigentlich nur noch 2 Möglichkeiten: du machst eine komplette Neuinstallation, bei der du aber alle alten Daten verlierst, oder du lässt jemanden auf deinen Server, der versucht die Installation wieder zum Laufen zu bringen

  • Options

    Das ist der aktuelle Fehlercode Fatal error: Class 'VanillaModel' not found in /home2/ersatzte/public_html//plugins/FileUpload/class.mediamodel.php on line 11

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited May 2016

    Vielleicht müssen Sie erneut die Dateien zu installieren sieht aus wie sie beschädigt wurden oder IGHT hochladen nicht konkurrieren. Verwenden Sie Filezilla in Server hochzuladen. Und bitte stellen Sie sicher, dass Sie die config.php-Datei und die .htaccess-Datei zu speichern, bevor Sie aktualisieren. Die .htaccess-Datei überschrieben wird, weil es sich um eine versteckte Datei ist nur Sie auf Sie Server-Dateien zu sehen. Das wird Ihnen 404-Fehler.

    Sie müssen Protokoll für updating jederzeit folgen und dies bedeutet, dass Ihr Forum auf Standard-Modus zu setzen, indem alle Plugins deaktivieren und auch das Standard-Theme singen. Wenn Sie dies nicht tun können Sie einen 500-Server-Fehler.

    Sie müssen sicherstellen, dass Ihr Host PHP-Version 5 und höher unterstützt. Löschen Sie die Dateien in den Fang als RJ vorgeschlagen.

  • Options
    hgtonighthgtonight ∞ · New MVP

    @R_J said:
    I guess there is one very important information which will make support quite difficult: CartmanoutGermany is using a one click installer from his provider.

    I hate un-maintained one click installers (which is basically all of them!).

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    @R_J said:

    @vrijvlinder said:
    und auch das Standard-Theme singen

    Yes, it would never hurt to sing a standard theme while you are updating :lol:

    That is what I said, I do it all the time.

    @hgtonight said:

    @R_J said:
    I guess there is one very important information which will make support quite difficult: CartmanoutGermany is using a one click installer from his provider.

    I hate un-maintained one click installers (which is basically all of them!).

    Yes, even when you write to them to update it. Last time they asked me to take a satisfaction survey for their scripts, I told them they are offering outdated scripts with security vulnerabilities. They did nothing about it. They are still offering Vanilla 2.1

  • Options

    Hallo liebe Vanillas,
    meine Seite ist wieder da Dank der grossen Hilfe von R_J das ist ein echter Teufelskerl und ein echter Meister seiner Kunst. Es muss nur noch zu meiner Schande und R_J,s Schock von 2.0 haha mal auf 2.2 gebracht werden. Da hakt es noch an der Datenbank und der Installation beim 1 Click Installer. Denn der zeigt 2.2 an ist es aber nicht. Das scheint wie ja auch R_J sagt der aller letzte Mist zu sein. Ich danke euch allen fuer eure Hilfe und Muehe mit mir und ganz besonders natuerlich R_J fuer seine Hilfe 1000 Dank.

    Liebe Gruesse

    Cartman

    Dear Vanillas,
    my site is back thanks to the great help of R_J that's a real hotshot and a true master of his art. It just needs to my shame and R_J be brought haha ​​s shock of 2.0 times to 2.2. Because it hooks still in the database and install the 1 Click Installer. For the shows at 2.2 but it is not. That seems just as R_J says to be the last of all crap. I thank you all for your help and effort with me and especially of course for his help R_J 1000 thanks.

    Kind regards

    Cartman

Sign In or Register to comment.