HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Editor configuration setup was okay but won't apply

This discussion is related to the Advanced Editor Config addon.
ProsperProsper ✭✭
edited May 2016 in Vanilla 2.0 - 2.8

Editor configuration setup was okay but won't apply on discussion after "post discussion" button was clicked.
I noticed that this plugin says 'RequiredPlugins' => array('editor' => '>= 1.7.5'), whereas the advance editor version on installed forum is 1.7.2. Where can I download editor version 1.7.5?
Is it the reason "Advanced Editor Config 0.1" does not work on the forum (vanilla version 2.2.1)
Also, it does not show on mobile device even with mobilefriendly true statement

Comments

  • R_JR_J Ex-Fanboy Munich Admin

    @Prosper said:
    Editor configuration setup was okay but won't apply on discussion after "post discussion" button was clicked.

    I do not understand. Could you elaborate on that?

    I noticed that this plugin says 'RequiredPlugins' => array('editor' => '>= 1.7.5'), whereas the advance editor version on installed forum is 1.7.2. Where can I download editor version 1.7.5?
    Is it the reason "Advanced Editor Config 0.1" does not work on the forum (vanilla version 2.2.1)

    I don't know where I've found that version number. You are correct: I've changed it to 1.7.2 and uploaded a new version. It is also the reason why you cannot enable the plugin.

    Also, it does not show on mobile device even with mobilefriendly true statement

    The plugin has no interface which is relevant for mobile display. Itdoesn't influence the behavior of the advanced editor in the mobile version, though.

  • ProsperProsper ✭✭
    edited May 2016

    @R_J said:

    @Prosper said:
    Editor configuration setup was okay but won't apply on discussion after "post discussion" button was clicked.

    I do not understand. Could you elaborate on that?

    I checked "color" and "highlightcolor" from admin setting of "Advanced Editor Config 0.1" but the configurations did not work when I typed discussion and submitted.

  • R_JR_J Ex-Fanboy Munich Admin

    My plugin is working flawlessly: it allows you to toggle advanced editors settings and when you activate color and highlightcolor you can see the dropdowns for that ;)

    I think you have to use WYSIWYG format in order to be able to use that. Go to the advanced editors settings page (yourforum.com/settings/editor) and change default format to Wysiwyg.

  • ProsperProsper ✭✭

    Yes, my advance editor setting was previously on "HTML" format. After changing to Wysiwyg format, Advanced Editor Config plugin now works. Thank you for the plugin and directions.

    Is there a way to make Advanced Editor Config plugin to work on mobile device just like on desktop?

  • R_JR_J Ex-Fanboy Munich Admin

    You should understand that those questions are not related to my plugin but to the advanced editor.

    The editor doesn't have different configurations for desktop and mobile view. Some buttons have the CSS class "editor-optional-button" but you cannot influence which of them. Whether those buttons are shown or not is determined by a CSS style:

    /* Media query: Hiding non-essential buttons */
    @media (max-width: 767px) {
        .editor-optional-button {
            display: none !important;
        }
    
    

    You can try it out by making your browser window smaller: the button bar will look like it does on mobile.
    So in order to show all buttons, you would have to customize the CSS. And: no, I do not know how to do that ;-)

    Prosperrbrahmson
  • ProsperProsper ✭✭

    @R_J - thank you.
    I appreciate your helpful detailed comments and time.

  • rbrahmsonrbrahmson "You may say I'm a dreamer / But I'm not the only one" NY ✭✭✭

    @Prosper - I found a solution to activate the changes on narrower screens (and this opens the door to other changes) - I added the following through CSSEDIT:

    /* Media query: Hiding non-essential buttons */
    @media (max-width: 766px) {
        .editor-optional-button {
            display: inline !important;
        }
    }
    

    What happens is that while the buttons disappear at 767 width they reappear at 767 width, practically make them available again. Now, I don't really recommend doing that unless you set another rule to make them disappear at a still lower width because on a small phone the buttons don't leave much room for editing.

    Prosper
  • ProsperProsper ✭✭

    @rbrahmson - thank you. It worked.

  • jobbatamjobbatam Batam New

    Where is font size & and font family? i dont see in my forum..

    thanks.. @R_J

  • hgtonighthgtonight ∞ · New Moderator

    @jobbatam said:
    Where is font size & and font family? i dont see in my forum..

    thanks.. @R_J

    Click on the A icon and you should see a list of fonts. The size is in the paragraph icon.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    R_J
  • jobbatamjobbatam Batam New

    In my forum,, I get this


    I dont see font size :cry:

    Font type, I See!

Sign In or Register to comment.