Couldn't find a Vanilla Forum at this url :/

i have installed vanilla forum in my wordpress directory called forum(http://website/forum). Anytime i want to validate the url it gives me this error "Couldn't find a Vanilla Forum at this url :/". I have gone through all possible solutions from here but i still get the same error. And 'cos of that embedding into other sites doesn't work. Can someone help me out?

Comments

  • LincLinc Director of Development Detroit Vanilla Staff

    Yes, there is a known bug in the WordPress plugin. I'm trying to get a new release out. In the meantime, the fix is here: https://github.com/vanilla/wordpress-vanilla/pull/9/files

    hgtonightwhu606jackmaessen
  • OK THANKS @Linc

  • LincLinc Director of Development Detroit Vanilla Staff

    I've released 1.1.17 with this fix.

    hgtonightMoehrensteinjackmaessen
  • I tried with the bugfix in (it was already in there), still having trouble with this.

    My forum is at buildcup.com, could you help me find out what url to put into the setup?

    Thanks a ton for your help.

  • It might be as when you click "discussions" it brings you to /discussions and when you click on a discussion it turns to /discussion?

    It seems to be like that by default though.

  • Matt2kMatt2k New
    edited May 2017

    This occurs when you have enabled the "Private communities" plugin. The validation function accesses your base forum URL and looks for a forum. If it returns a redirect to your wordpress login page instead, the validation function doesn't register.

    There's also a bug in the "Private communities" plugin. Disabling the plugin doesn't open your site back up. You have to disable the settings then disable the plugin.

    Restrict access to the discussion forums by editing the Guest user's permissions instead.

    vrijvlinder
Sign In or Register to comment.