How to disable jsConnect that is stuck in login loop

Hi, I implemented Vanilla forums jsconnect SSO with my django project. Something went wrong with my configuration and when I go to the Forum url it automatically goes to my website. I can't get to the Vanilla dashboard to disable jsConnect. If I'm not logged into my site, when going to the forum it will prompt me to login to my site (due to SSO). After logging in it goes to my site, not the forum. How can I stop this loop??

Tagged:

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    If you can't access the dashboard to disable a theme or plugin, you can disable it via the config.php and change TRUE to FALSE whatever you need to disable or edit. This is the back door to the settings.

  • Thx. Tried that and it still redirects me to my login. :-( I even changed access to jsconnect directory to 000.

    To be sure I'm working in the proper directory I set the parent forum directory to 000 and successfully blocked access.

    It seems the redirect url is set somewhere other than the plugin.

  • LincLinc Director of Development Detroit Vanilla Staff

    It is. The 'Default' column on the GDN_AuthenticationProvider table needs to be set to zero. This is being corrected in a future release.

    You can also login at /entry/password even when jsConnect is enabled.

    Bleistivthgtonight
Sign In or Register to comment.