Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

/utility/update does not exist?

This discussion is related to the Vanilla addon.
AristaPAristaP New
edited December 2016 in Vanilla 2.0 - 2.3

I just uploaded all files of version 2.3 to upgrade from 2.2.1 and when I try to run:

myforum.com/utility/update

There's a 404 error message. I just noticed that the folder /utility does not exist, so I don't know how the full path you suggest on your Upgrading instructions work.

Please help.

Thank you.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If you do not use "pretty urls" you would need to use example.com/index.php?p=/utility/update

    AristaP
  • LincLinc Director of Development Detroit Vanilla Staff

    Find the line with RewriteUrls in your config and delete the entire line.

  • LincLinc Director of Development Detroit Vanilla Staff
    edited December 2016

    This could've been explained better. First, I have added a note to that line in the Upgrading docs:

    (404? See next paragraph.)

    And then the next paragraph is now:

    If your forum still uses URLs including ?p=:

    Support for this URL structure is ending after 2.3 in favor of "pretty" URLs so it's time to make the switch. First, confirm your server is setup to handle rewrites. On Apache, using the .htaccess file provided will accomplish this. Additional setup is required on nginx and other platforms. Test whether it is working by visiting /discussions - if you see a discussions list (rather than a 404), it is likely setup correctly. Then, open conf/config.php and find the line with $Configuration['Garden']['RewriteUrls'] = false; and delete the entire line. Your site should immediately switch to "pretty" URL paths instead of using the 'p' parameter. If there is a problem, re-add the line to your config and do further troubleshooting.

  • @AristaP said:
    I just uploaded all files of version 2.3 to upgrade from 2.2.1 and when I try to run:

    myforum.com/utility/update

    There's a 404 error message. I just noticed that the folder /utility does not exist, so I don't know how the full path you suggest on your Upgrading instructions work.

    Please help.

    Thank you.

    you sound like you are relatively new to Vanilla.

    I suggest you see this commonly asked question regarding utility/update in the frequently asked questions in the tutorials section.

    Question 17
    https://vanillaforums.org/discussion/comment/219687/#Comment_219687

    this and other simple user questions are answered in https://vanillaforums.org/discussion/28420/frequently-asked-questions

    Also there is not a direct correlation /utility/update being a direct folder relation.

    utility - refers to the utility controller and update refers to the method in the controller.

    https://github.com/vanilla/vanilla/blob/ec5b13f6713dae42cd835267cea328d8e8559432/applications/dashboard/controllers/class.utilitycontroller.php#L220

    there is probably more info about this here: http://docs.vanillaforums.com

    regarding 404 errors - it could mean if you are using .htaccess and a webserver that reads .htaccess that your .htaccess is incorrect or does not allow overrides or that you are not using pretty url's - also described in the fAQ
    https://vanillaforums.org/discussion/comment/220157/#Comment_220157

    or it could be you are using some other web server that is not using .htaccess and you need to specify what it is or ask your host if pretty url's don't work for you.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    AristaP
  • @R_J said:
    If you do not use "pretty urls" you would need to use example.com/index.php?p=/utility/update

    I wasn't aware of such feature (Pretty URLs). Thanks to your advice, by adding index.php?p=, I was able to complete the update.

  • @Linc said:
    This could've been explained better. First, I have added a note to that line in the Upgrading docs:

    (404? See next paragraph.)

    And then the next paragraph is now:

    If your forum still uses URLs including ?p=:

    What Upgrading docs. When reading the directions to the upgrade, I was redirected to this page:

    https://github.com/vanilla/vanilla#upgrading

    And there's no note in there yet. Please let me know other Upgrading docs I'm not aware of.

    Also, I cannot find any htaccess file in the vanilla-core-2-3 folder I downloaded to upgrade. Since it's obvious I'm not using the Pretty URLs feature, please let me know how to enable them. And I wonder what will happen with the current URLs already indexed by Google when I switch from:

    domain.com/index.php?p=/discussion/...

    To:

    domain.com/discussion/...

    Thanks again!

  • @Linc said:
    Then, open conf/config.php and find the line with $Configuration['Garden']['RewriteUrls'] = false; and delete the entire line.

    I have just checked my /conf/config.php file and there is no such line in there.

  • K17K17 Unlosk · Français / French ✭✭✭

    @AristaP a dit :

    @Linc said:
    Then, open conf/config.php and find the line with $Configuration['Garden']['RewriteUrls'] = false; and delete the entire line.

    I have just checked my /conf/config.php file and there is no such line in there.

    If the line is not here, It's because thé default config isn't changed. The default config is in /config-defaults.php.
    If you need to change one setting in this file, you just need to add the line to your config.php (at the end to prevent errors). Never edit the config-default file.

    Lincvrijvlinder
  • @K17 said:

    @AristaP a dit :

    @Linc said:
    Then, open conf/config.php and find the line with $Configuration['Garden']['RewriteUrls'] = false; and delete the entire line.

    I have just checked my /conf/config.php file and there is no such line in there.

    If the line is not here, It's because thé default config isn't changed. The default config is in /config-defaults.php.
    If you need to change one setting in this file, you just need to add the line to your config.php (at the end to prevent errors). Never edit the config-default file.

    Even though I appreciate your reply, @K17, I'm afraid it is adding even more confusion. The directions quoted on this thread only mention the file /conf/config.php. There is no indication to edit any /config-defaults.php file.

    And the directions say I have to find and delete a line, not to add as you mentioned.

    :(

  • K17K17 Unlosk · Français / French ✭✭✭
    edited December 2016

    @AristaP I just explain how the config works in vanilla, and why its not à problem when a Line isn't in the config.php file ^^
    (Because you don't find the line who @Linc was talking about)
    Linc say to remove this Line because in 2.3 this setting is set to true (default value),but you just upgraded from 2.2.* where the default value for this Line is false.
    This is the line who enable ths "Pretty URLs" (yourforum.com/discussions instead of yourforum.com/index.php?p=/discussions using Apache's Rewrite Rule)

    AristaP
  • Ok, I see. Thanks for the insight @K17, I appreciate it. :)

Sign In or Register to comment.