Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

PHP Fatal error after upgrading from 2.2.1 to 2.3

This discussion is related to the Vanilla addon.

Hi,

I just wanted to let you know that after upgrading one of my forums from 2.2.1 to 2.3 there was a PHP Fatal error:

PHP Fatal error: require_once(): Failed opening required '/home/username/public_html/vendor/autoload.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/username/public_html/bootstrap.php on line 50

Fortunately to me, I decided to switch to PHP 7.x right away and by doing so, the site was magically fixed and no further PHP errors came up.

Comments

  • LincLinc Vanilla's Bard (and Director of Development) Detroit Vanilla Staff

    There's nothing inherently different about how PHP 5 vs PHP 7 includes files. If you truly 1) changed nothing else between upgrading PHP versions, 2) were already at least on PHP 5.4, 3) used the version for download on this site, and 4) the files were finished uploading and did so correctly, I'd chalk this up to something weird in your server config.

  • I'm just describing the facts as they happened.

    I used the cPanel (hosting control panel) feature to switch from one PHP version to another.

    As you can see from the excerpt, I was using PHP 5.6.

    Yes, I used the version for download from this site.

    All files were uploaded properly.

    And as I said, just by switching PHP versions (from 5.6 to 7.x), the error was gone and the site started to load properly again.

  • LincLinc Vanilla's Bard (and Director of Development) Detroit Vanilla Staff

    @AristaP said:
    I'm just describing the facts as they happened.

    And I was just providing a checklist of things to confirm. I don't have enough information to do any more than that.

  • Thanks @Linc, I appreciate it. :)

Sign In or Register to comment.