Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Strange error whit 2.3

Hi there,

Recent I start to use vanilla forum free and install it on my new website http://roboticants.com , then I made a new theme whit HTML5 and CCS3 , so I can make it unique, so I learn some HTML and CSS and made the theme for vanilla forum coled Black ant 1.0.

I made the theme and test it on a LAMP server installed on my PC and all thinks are ok, it work perfect, but when I put the them on my website I got 2 errors and one of this is look like this :

DraftModel->delete(int) is deprecated. Use DraftModel->deleteID(int) instead.

This error is appear when I try to write in comments or when I try to make a new discussion. i am not an expert but I think this is an error from PHP .

Do someone have have ideea what is and how can I fix it????

The other error was similar but about the user. The think is that I installed vanilla forum 2.3 and did a lot a work to make my custom theme to work :(

I will try to make new settings and reinstall the forum, but I need some opinions. I don't know what is the difference that make this error happen.

Comments

  • Can you place source code of your theme to filehosting, like http://sendspace.com ?
    I'll try to help you.

  • It give me more errors and I remade the install of the forum e reuploud the theme , the new error :-1:

    { "Code": 16384, "Exception": "DraftModel->getCount(int) is deprecated. Use DraftModel->getCountByUser() instead.", "Class": "Gdn_ErrorException" }

    I think that the a develop the theme on LAMP server PHP 7.o and the host that I use for the forum is a server whit version PHP 5.5 and this may cause the problem.

    On LAMP server on my PC is working perfect whit no issus.

  • @Twissell said:
    Can you place source code of your theme to filehosting, like http://sendspace.com ?
    I'll try to help you.

    Is not the theme , is working on my PC whit no problems, ad is a simple theme in HTML5 and CCS.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    What you see is not an error but only a warning. In Vanillas index.php you find ini_set('display_errors', 0); Maybe your online host is overriding this setting or simply disallows you to use this command and the default is to show notices? I would go and ask them about it.

  • @R_J said:
    What you see is not an error but only a warning. In Vanillas index.php you find ini_set('display_errors', 0); Maybe your online host is overriding this setting or simply disallows you to use this command and the default is to show notices? I would go and ask them about it.

    You my be right. Now I made a lot of tests and i get alot of this pop ups ans some errors. On my server whit LAMP is not having problems.

    Steel I think that is the difference of the PHP server and restrictions that my hos has on this :(

    How do I do now whit vanilla forum?!?!? in this condission I can't use it :(

  • I guess that you have mixed code of 2.2 and 2.3 branches in your project.
    Anyway there is getCount function implementation in Vanilla 2.3

    https://fossies.org/diffs/vanilla-Vanilla/2.2.1_vs_2.3/applications/vanilla/models/class.draftmodel.php-diff.html

  • @Twissell said:
    I guess that you have mixed code of 2.2 and 2.3 branches in your project.
    Anyway there is getCount function implementation in Vanilla 2.3

    https://fossies.org/diffs/vanilla-Vanilla/2.2.1_vs_2.3/applications/vanilla/models/class.draftmodel.php-diff.html

    :( It is a diference of MySQL version.

    On my PC I have vs MySQL 7.0 and on my hosting server is MySQL 5.5 or 5.3 :( and my theme is not working :( because on my PC is a different of MySQL and I optimize my theme for MySQL 7.0

    Thanks for the help, now I need to use new theme and after 20 days of work to learn HTML and CSS and make this black theme for nothing.... , I am sad :(

  • Don't be so upset about it =)
    Could you update MySQL version on production host? Why not just to do so?

  • i just tried 4 more theme that I tuck from vanilla forum themes, and the pop up are steel present , so my conclusion is the there is nothing wrong whit the theme, but whit the server of the host. :(

    Now I will try what you sad Twissell.

  • Waching in :-1:

    Server version: 5.6.34 - MySQL Community Server (GPL)

    And I dev this theme on ver 7.00 :(

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The easiest thing would be to ask your provider.

    If you like to test some things on your own, you could search for a file called php.ini and see if you find the error level set there...

  • I agree with previous participant, check you settings in php.ini at production host

  • I am back, where can I find that file php.ini?!?!?!?
    My host has a lot of restrictions :(

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Add this file the root of the forum and then enter into the search bar

    yoursite.com/phpinfo.php

    It will list what modules are enabled and everything

  • edited January 2017

    Desable function :
    allow_url_fopen, dl, escapeshellarg, escapeshellcmd, exec, link, passthru, proc_open, popen, syslog, system, pcntl_exec, pcntl_fork, pcntl_signal, pcntl_waitpid, pcntl_wexitstatus, pcntl_wifexited, pcntl_wifsignaled, pcntl_wifstopped, pcntl_wstopsig, pcntl_wtermsig, shell, shell_exec, symlink, system_exec, mkfifo, ini_restore

    This are all function that they say that are disabled.

    And this are the PHP settings :

    Php Info
    functia mail(): on
    display_errors: on
    memory_limit: 256MB
    max_execution_time: 60 (secunde)

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Please make sure that you have the following line in your index.php: ini_set('display_errors', 0);

    If you find something like ini_set('display_errors', 1); please change it and your problem is solved


    If the line looks like ini_set('display_errors', 0);, your hoster is the problem. Send them this code snippet and tell them that despite of this line in your code, you still see E_USER_WARNINGs in your script. They have to tell you how to disable this, we will not be able to help


    If your hoster sucks that much that they are not able to help, look at this: https://github.com/vanilla/vanilla/commit/1c70c29ca5fc3d48b7fca48f4b343696ae255ec5
    You should be able to find the lines in your installation and change them accordingly. They are the reason for the warning.

Sign In or Register to comment.