Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Gdn_Validation SphinxSearchPlugin

This discussion is related to the SphinxSearch addon.

Hello,
On step 3(Optional)

I'm getting the following error:

Call to protected method Gdn_Validation::AddValidationField() from context 'SphinxSearchPlugin'

Whats wrong?

Comments

  • Full error:

    Fatal Error in SphinxSearchPlugin.Controller_InstallWizard();
    
    Call to protected method Gdn_Validation::AddValidationField() from context 'SphinxSearchPlugin'
    The error occurred on or near: /var/www/html/vanilla5/plugins/SphinxSearch/class.sphinxsearch.plugin.php
    346:                     }
    347:                     break;
    348:                 case 'Config': // AKA cron setup
    349:                     $Sender->SetData('NextAction', 'Config'); //in case it fails
    350:                     $this->ConfigurationModel->Validation->AddValidationField('Plugin.SphinxSearch.IndexerPath',$_POST);
    351:                     $this->ConfigurationModel->Validation->AddValidationField('Plugin.SphinxSearch.ConfPath',$_POST);
    352:                     $Sender->Form->Save();
    353:                     if (!$Sender->Form->Errors()) {
    354:                         $SphinxAdmin->InstallCron();
    Backtrace:
    [/var/www/html/vanilla5/library/core/class.plugin.php:336] SphinxSearchPlugin->Controller_InstallWizard();
    [/var/www/html/vanilla5/plugins/SphinxSearch/class.sphinxsearch.plugin.php:234] Gdn_Plugin->dispatch();
    [/var/www/html/vanilla5/library/core/class.dispatcher.php:313] SphinxSearchPlugin->PluginController_SphinxSearch_Create();
    [/var/www/html/vanilla5/index.php:44] Gdn_Dispatcher->dispatch();
    
  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    Are you using the versoin from github or the download zip from the plugins site? This was solved a while ago and I haven't uploaded the new version to the plugins site. I Just recommend people to use the latest on github. @see here: https://github.com/mcuhq/SphinxSearchPlugin/issues/19

  • Yes, i've fixed it using the version on github.
    But i have another problem, indexes are not updated
    New posts and discussions wont show up.
    No errors in log

    this is my cron.reindex.delta.php:

                     <?php  /*
             * Add the following cron job to update the delta index every 2 hours
             */
            // 0 */2 * * * /usr/bin/php /var/www/html/vanilla5/plugins/SphinxSearch/cron/cron.reindex.delta.php
    
            define('PATH_TO_SPHINX_INDEXER', '/usr/bin/indexer');
            define('PATH_TO_SPHINX_CONFIG', '/etc/sphinxsearch/sphinx.conf');
            define('SPHINX_INDEX_NAME', 'vss_');
    
            $Command = PATH_TO_SPHINX_INDEXER." --config ".PATH_TO_SPHINX_CONFIG." ".SPHINX_INDEX_NAME."delta --rotate >> /var/www/html/vanilla5/plugins/SphinxSearch/cron/sphinx_cron.log 2>&1";
            exec($Command);
    

    Paths are correct in other files too

  • mcu_hqmcu_hq yippie ki-yay Arizona, USA ✭✭✭

    For those still following, it has been solved: https://github.com/mcuhq/SphinxSearchPlugin/issues/21

    hgtonightgiacomosilliOlivaw
Sign In or Register to comment.