Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Problems installing vanilla2.3

I downloaded vanilla 2.3 from https://open.vanillaforums.com/download
I unzipped the zip file and moved the contents to mySite/vanilla/
I changed the access for vanilla/cache/ vanilla/uploads/ and vanilla/conf using chmod -R 777
When I access mySite/vanilla I get:

Index of /vanilla

and a list of files and subdirectories

if I double click 'index.php' I obtain an error message:

Not Found
The requested URL /vanilla/dashboard/setup was not found on this server.

No dashboard appears.

What's wrong?

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Did you change the htaccess file to point to your Vanilla subfolder?

  • yes i did:

    Modified

    If you modify this file then change the above line to: # Modified


    RewriteEngine On

    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /vanilla
    
    RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&([^?]+))?$
    RewriteRule ^index\.php %1?%3 [E=X_REWRITE:1,L]
    
    # The basic rewrite rule.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
    
    # Add the proper X_REWRITE server variable for rewritten requests.
    RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
    RewriteCond %{ENV:REDIRECT_X_PATH_INFO} (.+)
    RewriteRule ^index\.php - [QSA,E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,E=X_PATH_INFO:%1,E=!REDIRECT_X_PATH_INFO,L]
    
    # 301 redirect urls that start with index.php
    #RewriteCond %{REQUEST_METHOD} GET [NC]
    #RewriteCond %{REQUEST_URI} ^(.*?)/index\.php(.*)$
    #RewriteRule ^index\.php /%1%2 [QSA,R,L]
    



    Header set Cache-Control "max-age=315360000"
    Header set Expires "31 December 2037 23:59:59 GMT"

  • kopnakopna Coimbra Portugal ☯
    edited January 28

    :o
    1. читаем/we read тут/here если непонятно, используем google translate/ use google translate
    2. устанавливаем/installation
    3. - копируем скачанные файлы в /copy the downloaded files to/ /public_html на вашем хостинге/on your hosting
    4. - создаём базу данных/create database имя/name ваш домен/host user_name/ник пользователя password/ваш пароль
    5. запускаем в браузере index.php/ runs in browser index.php ваше доменное имя/your domain name, например/example: http://your domain.com/index.php
    6. где используем ваше/where your use имя/name ваш домен/host user_name/ник пользователя password/ваш пароль + созданный вами аккаунт администратора/ created an administrator account you
    7. Всё/ The End

  • kopnakopna Coimbra Portugal ☯

    I had the same problem with the file .htaccess Vanilla 2.3 I changed to an ordinary file .htaccess on Vanilla 2.2.1

  • Can you tell me what to change in the .htaccess file?

  • kopnakopna Coimbra Portugal ☯

    @anton53 said:
    Can you tell me what to change in the .htaccess file?

    Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

  • kopnakopna Coimbra Portugal ☯
    edited January 28

    @anton53 said:
    No change!

    if you change the file .htaccess

    put before this # RewriteBase /, Excuse me!

  • Still no result. Maybe there is a php package missing. I am using php7.0, which php packages are required?

  • Solved:
    a2enmod rewrite

  • kopnakopna Coimbra Portugal ☯

    @anton53 said:
    Solved:
    a2enmod rewrite

    what exactly solve the problem?

  • ultDAultDA New
    edited June 11

    What specifically resolved this issue?

    I am having the same problem. When browsing to the default directory i get the following 404 error:

     Not Found
    
     The requested URL /dashboard/setup was not found on this server.
    
      Apache/2.4.18 (Ubuntu) Server at ec2-52-25-128-181.us-west-2.compute.amazonaws.com Port 80
    

    There is not a /dashboard/setup directory. This is a fresh installation in AWS using Ubuntu 16.04 LTS - PHP 7.0.18, MySQL 5.7.18, OpenSSL 1.0.2g, and Vanilla Forums 2.3.1. The .htaccess file has been modified to the following:


    RewriteEngine On

    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
     RewriteBase /
    

    No other modifications to the .htaccess have been made. I also tried using the .htaccess file from 2.1 without any luck.

    I have updated the permissions on the /cache, /conf, /uploads directories with (chmod +777) and have restarted the Apache service (sudo service apache2 stop/start). I've been trying to work through this for the last week. I've reviewed a number of different posts.

    If anyone could provide some insight into what could be causing this error i would very much appreciate it!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 11

    Ok, forgive the inaccurate info... you don't need 777 chmod ever... 775 max

    You must make sure you have the Rewrite Module enabled in your server for this installation. To find out if you do or don't have it enabled you need to look at your php.ini file.

    Create a php file called phpinfo.php
    paste this into it and put it in the root of your vanilla installation

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    

    Then go to yoursite.com/forum/phpinfo

    report what the settings are for Rewrite Module ...

    Delete the .ini files from the forum cache when ever you modify any files in the installation.

  • mod_rewrite is reported under the loaded modules

    Under Directive:
    url_rewriter.tags a=href,area=href,frame=src,input=src,form=fakeentry a=href,area=href,frame=src,input=src,form=fakeentry

    here's some more output:

    PHP logo
    PHP Version 7.0.18-0ubuntu0.16.04.1

    System Linux ip-172-31-22-228 4.4.0-1013-aws #22-Ubuntu SMP Fri Mar 31 15:41:31 UTC 2017 x86_64
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php/7.0/apache2
    Loaded Configuration File /etc/php/7.0/apache2/php.ini
    Scan this dir for additional .ini files /etc/php/7.0/apache2/conf.d
    Additional .ini files parsed /etc/php/7.0/apache2/conf.d/10-mysqlnd.ini, /etc/php/7.0/apache2/conf.d/10-opcache.ini, /etc/php/7.0/apache2/conf.d/10-pdo.ini, /etc/php/7.0/apache2/conf.d/20-calendar.ini, /etc/php/7.0/apache2/conf.d/20-ctype.ini, /etc/php/7.0/apache2/conf.d/20-exif.ini, /etc/php/7.0/apache2/conf.d/20-fileinfo.ini, /etc/php/7.0/apache2/conf.d/20-ftp.ini, /etc/php/7.0/apache2/conf.d/20-gettext.ini, /etc/php/7.0/apache2/conf.d/20-iconv.ini, /etc/php/7.0/apache2/conf.d/20-json.ini, /etc/php/7.0/apache2/conf.d/20-mcrypt.ini, /etc/php/7.0/apache2/conf.d/20-mysqli.ini, /etc/php/7.0/apache2/conf.d/20-pdo_mysql.ini, /etc/php/7.0/apache2/conf.d/20-phar.ini, /etc/php/7.0/apache2/conf.d/20-posix.ini, /etc/php/7.0/apache2/conf.d/20-readline.ini, /etc/php/7.0/apache2/conf.d/20-shmop.ini, /etc/php/7.0/apache2/conf.d/20-sockets.ini, /etc/php/7.0/apache2/conf.d/20-sysvmsg.ini, /etc/php/7.0/apache2/conf.d/20-sysvsem.ini, /etc/php/7.0/apache2/conf.d/20-sysvshm.ini, /etc/php/7.0/apache2/conf.d/20-tokenizer.ini
    PHP API 20151012
    PHP Extension 20151012
    Zend Extension 320151012
    Zend Extension Build API320151012,NTS
    PHP Extension Build API20151012,NTS
    Debug Build no
    Thread Safety disabled
    Zend Signal Handling disabled
    Zend Memory Manager enabled
    Zend Multibyte Support disabled
    IPv6 Support enabled
    DTrace Support available, disabled
    Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
    Registered Stream Filters zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, convert.iconv.*, mcrypt.*, mdecrypt.*
    Zend logo This program makes use of the Zend Scripting Language Engine:
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.18-0ubuntu0.16.04.1, Copyright (c) 1999-2017, by Zend Technologies
    Configuration

    apache2handler

    Apache Version Apache/2.4.18 (Ubuntu)
    Apache API Version 20120211
    Server Administrator webmaster@localhost
    Hostname:Port :80
    User/Group www-data(33)/33
    Max Requests Per Child: 0 - Keep Alive: on - Max Per Connection: 100
    Timeouts Connection: 300 - Keep-Alive: 5
    Virtual Server Yes
    Server Root /etc/apache2
    Loaded Modules core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_mime prefork mod_negotiation mod_php7 mod_rewrite mod_setenvif mod_status
    Directive Local Value Master Value
    engine 1 1
    last_modified 0 0
    xbithack 0 0
    Apache Environment

  • if anyone could help that would be greatly appreciated!

    I've been working on this for days, ready every blog post possible, maybe every modification i can think of (newbie to Vanilla Forum) and still nothing. I get the following error regardless.

    Not Found

    The requested URL /forum/dashboard/setup was not found on this server.

    Apache/2.4.18 (Ubuntu) Server at compute.amazonaws.com Port 80

    I'm running up against an important deadline and have to start considering other optons. I really want to Vanilla work because of the time invested and feedback i've read.

    Thanks in advance!

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Use RewriteBase /forum instead of RewriteBase /

  • R_J - thanks you for the response; however its the same issue:

    Here's what i did ...

    Step 1: created a forum directory under "/var/www/html/forum/"
    Step 2: extracted 2.3 (2ZCYQN977HZZ.zip) to this new directory.
    Step 3: unzipped
    Step 4: sudo chmod -R 775 cache/ conf/ uploads/
    Step 5: modified the .htaccess file as recommended "RewriteBase /forum"

    ubuntu@ip-:/var/www/html/forum$ cat .htaccess

    Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On

    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
     RewriteBase /forum
    
    RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&([^?]+))?$
    RewriteRule ^index\.php %1?%3 [E=X_REWRITE:1,L]
    
    # The basic rewrite rule.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
    
    # Add the proper X_REWRITE server variable for rewritten requests.
    RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
    RewriteCond %{ENV:REDIRECT_X_PATH_INFO} (.+)
    RewriteRule ^index\.php - [QSA,E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,E=X_PATH_INFO:%1,E=!REDIRECT_X_PATH_INFO,L]
    
    # 301 redirect urls that start with index.php
    #RewriteCond %{REQUEST_METHOD} GET [NC]
    #RewriteCond %{REQUEST_URI} ^(.*?)/index\.php(.*)$
    #RewriteRule ^index\.php /%1%2 [QSA,R,L]
    



    Header set Cache-Control "max-age=315360000"
    Header set Expires "31 December 2037 23:59:59 GMT"

    Step 6: restarted apache (just in case)
    Step 7: tested in browser

    Chrome:
    Not Found

    The requested URL /forum/dashboard/setup was not found on this server.

    Apache/2.4.18 (Ubuntu) Server at ec2-52-25-128-181.us-west-2.compute.amazonaws.com Port 80

    FireFox:
    enabledApplicationFolders(); $dispatcher->enabledApplicationFolders($enabledApplications); $dispatcher->passProperty('EnabledApplications', $enabledApplications); // Process the request. $dispatcher->start(); $dispatcher->dispatch();

    Note:
    Before moving to the forum directory, manually using this url would get me to the admin setup page; however, when submitting the configs it would fail again.

    .compute.amazonaws.com/index.php?p=/dashboard/setup/

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please replace the contents of the htaccess file with this

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /forum
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    also make sure if you have already gone through the set up page , look inside the conf/config.php to see if ReWriteUrls is true... if not make it true instead of false. Both the htaccess and the config.php must have this matching.

    This was all explained in the tutorial category.. !!

    https://open.vanillaforums.com/discussion/25111/about-error-404-not-found

  • Thank you vrijvlinder - your help is very much appreciated!

    I did see that tutorial link but did not read it extensively because of the post date (2013) and i've been focused on 2.3.1.

    I made the modification you suggested with the .htaccess file. I backed up the original and input what you provided and i'm still getting the same 404 error "The requested URL /forum/dashboard/setup was not found on this server.".

    I do not have a "forum/conf/config.php" file.

    ubuntu@:/var/www/html/forum$ pwd
    /var/www/html/forum

    ubuntu@:/var/www/html/forum$ ls -al ./conf/
    total 32
    drwxrwxr-x 2 root root 4096 May 11 18:58 .
    drwxr-xr-x 13 root root 4096 Jun 13 05:29 ..
    -rwxrwxr-x 1 root root 13790 May 11 18:58 config-defaults.php
    -rwxrwxr-x 1 root root 2681 May 11 18:58 constants.php
    -rwxrwxr-x 1 root root 283 May 11 18:58 readme.txt

    I also don't see any ReWriteUrls configurations in config-defaults.php.
    ubuntu@:/var/www/html/forum/conf$ grep ReWriteUrls config-defaults.php
    ubuntu@:/var/www/html/forum/conf$

    ubuntu@:/var/www/html/forum$ ls -al ./cache/
    total 12
    drwxrwxr-x 3 root root 4096 May 11 18:58 .
    drwxr-xr-x 13 root root 4096 Jun 13 05:29 ..
    -rwxrwxr-x 1 root root 0 May 11 18:58 .gitkeep
    drwxrwxr-x 3 root root 4096 May 11 18:58 Smarty
    ubuntu@ip-172-31-22-228:/var/www/html/forum$

    Here's the current state of my system:

    installed directory : /var/www/html/forum

    directory permissions: drwxrwxr-x 3 root root 4096 May 11 18:58 cache
    drwxrwxr-x 2 root root 4096 Jun 13 06:12 conf
    drwxrwxr-x 2 root root 4096 May 11 18:58 uploads

    .htaccess file:

    ubuntu@i<hostname>:/var/www/html/forum$ cat .htaccess
     # Modified
     # If you modify this file then change the above line to: # Modified
     <IfModule mod_rewrite.c>
     RewriteEngine On
     # Certain hosts may require the following line.
     # If vanilla is in a subfolder then you need to specify it after the /. 
     # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
     RewriteBase /forum
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    Browser (Chrome & Safari): http:///forum/dashboard/setup

     Not Found
    
     The requested URL /forum/dashboard/setup was not found on this server.
    
      Apache/2.4.18 (Ubuntu) Server at <server> Port 80
    

    I'm not sure what to test at this point.

    I really appreciate this community providing all the assistance that it has in a short period of time. You can tell a lot from a product by the community; however, if i can't get this up and running by tomorrow afternoon I'll need to start looking at alternatives.

    If anyone has anymore ideas ... please let me know.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Add this line to your /conf/config-defaults.php: $Configuration['Garden']['RewriteUrls'] = false;

    Afterwards you should be able to install and use the forum. Try if at least this is working and your only problem is that .htaccess rewrite problem.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @ultDA said:
    Note:
    Before moving to the forum directory, manually using this url would get me to the admin setup page; however, when submitting the configs it would fail again.

    You have moved some files? Don't forget to delete all *.ini files in the /cache folder after that!

  • AWESOME - thanks!

    I am curious why that statement wasn't in the config-defalts.php file but i'm more happy we're up and running.

    Thanks again for the great commitment to the community. This is what makes good products great and loyal customers!

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Every possible config setting has a default value. There are a lot of things that you can do by adding some keys to the configuration. Many of them cannot be seen in Vanillas dashboard. Vanilla aims at a) being simple to use and b) being mighty for those who need that.

    If you stick with Vanilla you will see that there are a lot of good things under the hood that you cannot see and only bring up by adding something to the config.php (my favorite is $Configuration['Conversations']['Subjects']['Visible'] = true;) and if you go beyond that and start to develop, you will find a framework that makes even complex tasks really easy.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    But I think you should still try to solve the problem that you cannot use nice urls. Normally you shouldn't make any changes to the config-defaults.php file. So you should better move that line from config-defaults to the config.php file

    Then you would have to try again. Is your forum really at www.example.com/forum? Try again that "old" and simple .htaccess file and use RewriteBase /forum, setting the config entry to "true"

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 13

    Regardless of the age of that tutorial , it still applies and if you had read it carefully you would have solved this a long time ago. Making us repeat the same info over and over is redundant . Why do people fail to read the documentation and the tutorials ??? Why did we bother writing them ? Glad you sorted its t out, but still read the stuff . You will need it in the future anyway.

Sign In or Register to comment.