Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

How to resume auto save draft after plug in disabled?

I've disabled this plugin, but for some reason the website still acts as if auto-drafts are disabled. Is there anything I can do to get them working again?

Thank you for your time and help!

Comments

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Try deleting the settings for that plugin in the config.php if there are any.

  • Options

    @vrijvlinder said:
    Try deleting the settings for that plugin in the config.php if there are any.

    As strange as it sounds, it seems that it has resumed - perhaps I had a browser issue of some sort. I reuploaded the entire vanilla forums file package, so perhaps that helped. I also checked config.php just in case just to make sure everything was removed as per your advice.

    Could it be a case where the timing of the auto-save is perhaps is off and I'm just missing it? Can I change how often auto-save happens?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2017

    It probably has to do with caching. This might work for you.

    https://open.vanillaforums.com/addon/localdrafts-plugin

    The Stop auto save draft plugin basically just removes the java scripts file for drafts that saves from loading

    $Sender->RemoveJsFile('autosave.js');
    

    So inspect to see if it is loading or not.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    This is the contents of that file. I do not recommend editing that file. You can create a plugin to override the core file with your interval time.

    jQuery(document).ready(function($) {
        /* Autosave functionality for comment & discussion drafts */
        $.fn.autosave = function(opts) {
            var options = $.extend({interval: 60000, button: false}, opts);
            var textarea = this;
            if (!options.button)
                return false;
    
            var lastVal = null;
    
            var save = function() {
                var currentVal = $(textarea).val();
                if (currentVal != undefined && currentVal != '' && currentVal != lastVal) {
                    lastVal = currentVal
                    $(options.button).click();
                }
            };
    
            if (options.interval > 0) {
                setInterval(save, options.interval);
            }
    
            return this;
        }
    });
    
  • Options

    @vrijvlinder said:
    It probably has to do with caching. This might work for you.

    https://open.vanillaforums.com/addon/localdrafts-plugin

    The Stop auto save draft plugin basically just removes the java scripts file for drafts that saves from loading

    $Sender->RemoveJsFile('autosave.js');

    So inspect to see if it is loading or not.

    Alright, thanks for all this good info - I'll check it out. I appreciate the help!

Sign In or Register to comment.