Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Troubles installing Vanilla 2.3 on Ubuntu - Dashboard Setup page returning blank (empty)

edited March 2017 in Vanilla 2.0 - 2.8

I've been having trouble installing Vanilla Forums 2.3. Currently, when I try to access the server (which I have installed in /var/www/html/forum), I recieve a completely blank page with no information on it whatsoever, in Firefox. Accessing it from Internet Explorer gives a generic "the webpage cannot be found" error and accessing it from Google Chrome on my phone gives a generic "this page appears to be broken" error with Google's logo.

I have noticed that, when connecting to <IP>/forum, it redirects me to <IP>/forum/dashboard/setup, but the page's content remains the same (empty).

There is currently no ../forum/conf/config.php (due to me not even being able to get to the setup page), however modifying ../forum/conf/config-defaults.php (backing it up first, of course) seemed to have an effect when I disabled the "Rewrite URLs" thing (changing the redirect from <IP>/forum/dashboard/setup to <IP>/forum/index.php?p=/dashboard/setup, but the page otherwise remained blank. I guess this means something must be working correctly for the config to be read, but I guess it's getting stuck somewhere. Either way, I changed it back - I recall a post in another topic saying that Rewrite URLs are a requirement, and I only changed it for debugging purposes anyway.

I also noticed that enabling $Configuration['Debug'] = TRUE; in the config-defaults.php file has had no effect, though I don't know where the errors are supposed to appear anyway. Tried looking for a "logs" folder, to no avail. Also tried using the Vanilla 2.2 .htaccess file mentioned in this topic, but still nothing.

I'm at a bit of a loss of what to do now. I will also mention the WordPress website also hosted on the server (just connected to by the IP address regularly) works perfectly fine, so I doubt this is a connection issue. I expect there's just something I haven't done correctly during setup or something, but the guide to set up was... rather under-detailed, so I probably did something wrong somewhere.

If there's any extra information you need, please ask along with how to get the information you require. ;o I'm still fairly new this, so I'm not exactly sure on how to do everything yet. (Plus, my scatterbrained mind probably forgot something important :V)


  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Welcome to the community.

    Is your web server apache or nginx?

  • I'm using Apache. (Well, Apache2... but pretty sure that's standard by now.)

  • R_JR_J Ex-Fanboy Munich Admin

    Please search for the lines

    ini_set('display_errors', 0);
    ini_set('track_errors', 1);

    In your /index.php file and change the "0" to a "1" like that:

    ini_set('display_errors', 1);
    ini_set('track_errors', 1);

    Then report which error messages appear

  • Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /var/www/html/forum/library/core/class.dispatcher.php on line 543

    This is a "Not enough RAM" thing, isn't it. What's the recommended amount for Vanilla? ;o

  • R_JR_J Ex-Fanboy Munich Admin

    It just looks like that. I would guess what is happening is an infinite redirect loop. Please try to use the .htaccess file from version 2.2:

    And also you should change the config-defaults entry concerning the pretty urls:
    $Configuration['Garden']['RewriteUrls'] = false;

    They might be required for some plugins, but not for installation.

    If everythig works fine with that, we know what to fix ;)

  • Hm. Expanded the server to 1GB RAM (figured it needed it :V), used the 2.2 .htaccess file (truth be told, I was using it in the first place :V) Modified the .htaccess file to have RewriteBase set to /forum (and not commented out) and regarding the config-defaults thing.. well, I already did that. Figured it'd make debugging it easier and I could just as easily turn it off once everything's set up.

    However, the error remains exactly the same, even down to the allowed memory size. Hm.

  • R_JR_J Ex-Fanboy Munich Admin

    Oh yes, now I see that you have spoken about the .htaccess file from 2.2 in your initial post...

    Please check your Apache error logs for more information. They most probably can be found under /var/log/apache2

  • There doesn't appear to be anything out of the ordinary, other than the error I've already said. Noticing it says "PHP Fatal Error" instead of just "Fatal Error" in the logs, but the error is otherwise identical. The only other thing in the error logs is a [core:notice] thing AH00094: Command line: '/usr/sbin/apache2' and two [mpm_prefork:notice] things AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations and AH00169: caught SIGTERM, shutting down

    .. Those are in reverse order, by the way.

    Neither of those things in the logs seem particularly out-of-place. Looks like it's just the server getting shut down and starting back up to me (like I've done a few times), but I could be wrong.

  • R_JR_J Ex-Fanboy Munich Admin

    Sorry, I have no idea left. If I were you I would start testing wildly.

    Create a new folder (maybe called "vanilla"). Download a clean copy and unzip it to the server. If you have shell access, load it with wget directly from the command line.
    Try what you already tried: using new and using old .htaccess. Disable RewriteUrls
    Use RewriteBase /vanilla if that folder really is a sub folder of your root folder.
    With RewriteUrls = false, try to directly access a page that you put in the uploads folder.

    If nothing of that works, map that folder as a sub domain. Don't use RewriteBase then. Test everything you have tested before.

    If none of that helps, I would switch to nginx ;)

  • Why do I not think of the simplest things...

    Made a new folder (wanted the forum in /forum, so I just renamed the old one to /forum-old while working this out) and decided to install Vanilla via wget (instead of a FTP client) this time around.

    It just worked. Immediately. Why did I not think of this before.

    Either way, thank you! Not sure why this suddenly worked but I'm glad it did. :confounded: Maybe it's a file permissions thing, I have no idea. It works now, that's what matters.

  • R_JR_J Ex-Fanboy Munich Admin

    @MoricStorm said:
    It just worked. Immediately.

    Great! Go on and have fun =)

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @MoricStorm said:
    Why do I not think of the simplest things...

    Occam's Razor Principle is always the best approach ;)

  • donovanbdonovanb
    edited June 2018

    Going through the same... reinstalled vanilla 2.6 using wget from here:

    Unfortunately, same result... infinate loop looking for /dashboard/setup

    Here is my platform:

        ###php -v
        ea-php-cli Copyright 2017 cPanel, Inc.
        PHP 7.0.29 (cli) (built: Apr  5 2018 20:30:36) ( NTS )
        Copyright (c) 1997-2017 The PHP Group
        Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies

    Here is my .htaccess file:

    less .htaccess
    <IfModule mime_module>
      AddType application/x-httpd-ea-php70 .php .php7 .phtml
    <IfModule mod_rewrite.c>
        RewriteEngine On
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        #RewriteBase /
        # Make sure that / doesn't try to go to index.php without a rewrite :)
        DirectoryIndex disabled
        # Deny access to certain directories that SHOULD NOT be exposed.
        RewriteRule (^|/)\.git - [L,R=403]
        RewriteRule ^cache/ - [L,R=403]
        RewriteRule ^cgi-bin/ - [L,R=403]
        RewriteRule ^uploads/import/ - [L,R=403]
        RewriteRule ^vendor/ - [L,R=403]
        # Prevent access to any php script by redirecting the request to /index.php
        # You can add an exception by adding another RewriteCond after this one.
        # Example: RewriteCond %{REQUEST_URI} !^/yourscriptname.php$
        # You can comment out this section if it causes you problems.
        # This is just a nice to have for security purposes.
        #RewriteCond %{REQUEST_URI} !/index.php$
        #RewriteRule (.+\.php) [E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
        # Redirect any non existing file/directory to /index.php
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule (.*) index.php [E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
        # Add the proper X_REWRITE server variable for rewritten requests.
        RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
        RewriteCond %{ENV:REDIRECT_X_PATH_INFO} (.+)
        RewriteRule ^index\.php - [E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,E=X_PATH_INFO:%1,E=!REDIRECT_X_PATH_INFO,L]
    <IfModule mod_headers.c>
       <FilesMatch "(?<!embed)\.(css|js|woff|ttf|eot|svg|png|gif|jpeg|jpg|ico|swf)$">
          Header set Cache-Control "max-age=315360000"
          Header set Expires "31 December 2037 23:59:59 GMT"

    Notice that I have to add

    <IfModule mime_module>
      AddType application/x-httpd-ea-php70 .php .php7 .phtml

    which is how cPanel enacts PHP 7.

    I wouldn't think that would cause a problem though. If I remove it, I just get a notice that php 7 is required.



  • uhg, I think this code formatting left a few things out.. but you I guess you get the idea. :-)

  • R_JR_J Ex-Fanboy Munich Admin

    I've cleaned up the code. Enclose multi line code in ~~~ above and below the code

  • Thanks @R_J .. see my post in 2.6 help for answer to my issue.

Sign In or Register to comment.