Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Fatal Error in Gdn_Database.Query();

I recently have some trouble accessing the dashboard of my forum. When I turned on the debug, I got this error message

Here's my Vanilla's app info
Additional information for support personnel:
Application: Vanilla
Application Version: 2.1.8p2
PHP Version: 5.6.28
Operating System: Linux
Server Software: Apache/2.4.23 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36
Request Uri: /forum/dashboard/settings/jsconnect
Controller: Gdn_Database
Method: Query

Have anyone ever seen this before?

Thanks!

Comments

  • x00x00 MVP

    You vanilla version is way out of date. I could sit here diagnosing it for you, but really you aught to be more concerned about the security vulnerabilities.

    grep is your friend.

  • Yeah my boss would like to keep this version. Is the issue because of the database?

    We moved from a hosting to another. Previously it was working fine. I have checked all of the config files and they are all correct.

    Thanks!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited June 20

    @menshinobi

    Nothing to do with the DB error, but you need to find a way to tell your boss she or he is nuts, and is putting the site server and users at risk by not updating.

    For my part, I wouldn't want to support someone who refused to take the security of their site and users seriously.

  • x00x00 MVP
    edited June 21

    I don't think the version of php you are running is even compatible with the version. I think vanilla 2.1 was compatible with 5.3 maybe 5.4 at a stretch not 5.6

    You need to update vanilla becuase you are running an insecure version.

    grep is your friend.

  • Ok thanks, I will update my Vanilla forum now and get back to you

  • So after I upgraded the forum, I met this bug

    I have no idea on how to solve it. Any ideas?

    Thanks!

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Deactivate the plugin Participated (if you cannot access the dashboard, remove the corresponding line in /conf/config.php.
    Afterwards re-enable it in the dashboard (NOT! by simply changing the config).

    Please report back if that has solved your problem.

  • Hi R_J,

    Thanks for your help but still no luck.

    Here is the screenshot of my conf file

    After I cleared my cache and refresh the forum page, the bug is still there.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Please run example.com/utility/structure, there seems to be some problems with your database structure. Normally that should have been fixed on a normal upgrade...

  • Thank you! That fixes it!

Sign In or Register to comment.