Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Can't install Vanilla 2.3.1

I have installed Vanilla 2.3.1, base on these instructions (https://github.com/vanilla/vanilla/blob/master/README.md)
But when I surf to the main page I'm redirected to /dashboard/setup, and than get to error 404

BTW - If I'm using this url http://my-domain/index.php?p=/dashboard/setup, I do get to the setup page,
but after filling all the data and clicking the 'Continue' button, I again redirect to /dashboard/setup, and than get to error 404.

I'm using:

  • Ubuntu 16.04.2 LTS
  • Apache/2.4.18
  • PHP Version 7.0.22
  • mysql Ver 14.14 Distrib 5.7.20, for Linux

These are the steps I did.
1. create directory /var/www/html/vanilla
2. unzip the vanilla code into this directory
3. sudo chown www-data:www-data -R /var/www/html/* ; sudo chmod -R 777 /var/www/html/*
4. on the file .htaccess I set RewriteBase to /vanilla/

Beside that I have tried lots of other suggestion that I have found on this forum, non did help.
I saw suggestion to use the .htaccess from version 2.2, but I couldn't find that file, so I didn't tried that.

I'm working on it for hours, with no results
Please help.

Thanks,
Gal

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @galb said:
    I saw suggestion to use the .htaccess from version 2.2, but I couldn't find that file, so I didn't tried that.

    But I bet that will solve your problems :wink:

    You can download older versions from the download section

  • Thank you R_j for your response,
    unfortunately I still got the same error.
    I reinstall, and just replace the .htaccess file and it didn't work.
    I also reinstall it directly on /var/www/html, and I still get the same error.
    Any other suggestions?

  • galbgalb New
    edited October 2017

    Hi
    I finally manage to run vanilla =)
    Since I try so many think I'm not 100% what solve the problem
    but I think it was these two thinks:
    1. using .htaccess from 2.2
    2. on the file /etc/apache2/sites-available/000-default.conf I added
    < Directory /var/www/html >
    AllowOverride All
    </ Directory >

    Gal

    R_J
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes it appears the htaccess file that comes with the latest version is wrong and it has not been fixed or even addressed ... not sure why but it has caused problems for everyone. And will continue to cause problems unless they remove it or fix it. Anyone who has this problem must delete the htaccess and use the oldest one available. The new one contains too many things that cause problems.

Sign In or Register to comment.