HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Dashboard menu items for Yaga missing

This discussion is related to the Yet Another Gamification Application addon.

Hello.

There used to be a menu item to edit reactions, but this is gone for some reason.

Any idea how to get this back? Or at least manual URL for reaction modifications..?

Using Vanilla 2,51 with the Cloudy theme.

Comments

  • Have the same problem. Quite frustrated with 2.5.1 and broken plugins.

  • solved by adding the following lines to config.php

    // Yaga
    $Configuration['Yaga']['Version'] = '1.1';
    $Configuration['Yaga']['Reactions']['Enabled'] = '1';
    $Configuration['Yaga']['Badges']['Enabled'] = '1';
    $Configuration['Yaga']['Ranks']['Enabled'] = '1';
    $Configuration['Yaga']['MenuLinks']['Show'] = '';
    $Configuration['Yaga']['LeaderBoard']['Enabled'] = '';
    $Configuration['Yaga']['LeaderBoard']['Limit'] = '';
    
  • @SugarFree : Surprised that worked. These lines were allready there in my config.php. Did you do anything else in addition?

  • Flower420Flower420 Munich New
    edited March 2018

    tried everything, bought even new VPS, to put there clean version of Vanilla with different configurations (centos, ubuntu, apache, nginx-phpfpm), and still tons of errors.. i give up.. even by adding these lines in the config doesnt helps..

  • I still have this issue. Does anyone know if these reactions can be edited in a code somewhere?

  • Two years later and I still have this issue.

    @R_J (mention not enabled?) helped me install bort the latest Vanilla version and the new Yaga.

    Still, I only have this one menu item for Yaga (Settings).

    Anyone else struggeling with this? Would love a solution!

  • Basically I cannot access these:

    (Images borrowed from https://open.vanillaforums.com/discussion/comment/261054#Comment_261054)

  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited June 15

    Did you upgrade to Vanilla 3.3?
    Did you uninstall the old YAGA in the applications folder and install the latest version from vanillaskins.com in your plugins folder?
    Can you access this URL in the dashboard https://www.yourforum.at/action/settings ?

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
    asleulv
  • Yes to all questions. Well, @R_J did (great help from him!).

    And YES, I am able to access that url!

    Could someone post the url to the manage badges page aswell?

    Thanks @phreak!

  • R_JR_J Ex-Fanboy Munich Moderator

    @phreak I just hope I haven't messed up the installation, but I'm confident that this is not my fault 😁

    That's a really weird problem and I simply guess it is a strange interaction of untranslated menu items and JavaScript or whatever. Here is how it looks like in the web inspector:


    As you can see the menu is there but collapsed and therefore invisible. 😕


    @asleulv I have expanded the links in the screenshot above so that you can see the links


    asleulvphreakBleistivt
  • R_JR_J Ex-Fanboy Munich Moderator

    Forget to mention @Bleistivt: do you have an explanation for that misbehaviour?


  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP

    @asleulv: Can you upload the language files in use somewhere and link to them so we can have a look?

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
    asleulv
  • I'm not at my computer right now @phreak, but guess what... You just SOLVED this years long mystery 🙌🙌🙌

    Switched to English and the menu items appeared!

    The Norwegian translation is Incredibly buggy anyways, so I'll just keep it like this.

    THANK YOU!

  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP

    Hurray! Consider helping to update the Norwegian translation so your folks don’t get confused as well. :)

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
    BleistivtR_J
  • @R_J after a lot of digging I think I found the cause: The way the NestedCollectionAdapter works is that it creates a key from the actual text which gets passed into addLink already translated:

    This creates a key using a translated string which then becomes a class name where a dot is replaced with a dash. If that class name contains a dash, a sublist is created which is then hidden by JS.

    So the fix could be to make sure the translated (or in this case untranslated) string never contains a dot:

    https://github.com/bleistivt/yaga/commit/cb180ac3c05be3ad4b03f9119f2b2c3b3045ac19

    R_Jasleulvphreak
Sign In or Register to comment.